Package Details: clang-lw-git 9.0.0_r315268.eb14dc7585b-1

Git Clone URL: https://aur.archlinux.org/clang-lw-git.git (read-only)
Package Base: clang-lw-git
Description: C language family frontend for LLVM
Upstream URL: https://clang.llvm.org/
Licenses: custom:University of Illinois/NCSA Open Source License
Conflicts: clang-analyzer, clang-tools-extra
Provides: clang=9.0.0_r315268.eb14dc7585b-1, clang-git=9.0.0_r315268.eb14dc7585b-1, clang-tools-extra=9.0.0_r315268.eb14dc7585b-1, clang-tools-extra-git=9.0.0_r315268.eb14dc7585b-1
Submitter: Lone_Wolf
Maintainer: Lone_Wolf
Last Packager: Lone_Wolf
Votes: 0
Popularity: 0.000000
First Submitted: 2019-04-06 15:27
Last Updated: 2019-04-29 22:52

Required by (410)

Sources (2)

Pinned Comments

Lone_Wolf commented on 2019-05-17 22:16

This package is now obsolete, switch to clang-minimal-git instead.

Latest Comments

frankyboy commented on 2019-05-19 16:22

@Lone_Wolf, yes,i need this workaroud when building with makepkg -si --nocheck same with clang-minimal-git

Lone_Wolf commented on 2019-05-17 22:16

This package is now obsolete, switch to clang-minimal-git instead.

Lone_Wolf commented on 2019-04-14 11:49

Frankyboy,

your comments kinda suggest you build with yay. Do you need that workaround when building with makepkg ?

frankyboy commented on 2019-04-14 09:02

managed to compile by changing llvm-project/clang/include/clang/Driver/Options.td include path to

include "/usr/include/llvm/Option/OptParser.td"

found here http://lists.llvm.org/pipermail/cfe-dev/2014-March/035926.html

frankyboy commented on 2019-04-13 19:15

@Lone_Wolf, have no clue why i got this error :D it didn't find file either in home/compile/.cache/yay/clang-lw-git/src/llvm-project nor in /usr/include/llvm/.

Lone_Wolf commented on 2019-04-09 18:53

Nope, but that's rather common for llvm trunk . When build fails due to tests, I use --nocheck to skip them.

Sometimes I get the impression llvm regression & unittests are mainly looked at when a release is close. (I haven't registered bugs for the failures, so a small part of the blame falls to me)

frankyboy commented on 2019-04-09 18:28

@Lone_Wolf, does llvm-lw-git pass all tests for you?

Lone_Wolf commented on 2019-04-07 17:43

Just verified, nothing wrong here with fresh rebuilds of llvm-lw-git & compiler-rt-lw-git . Please rebuild those, then try building clang-lw-git again.

Lone_Wolf commented on 2019-04-07 17:28

llvm/Option/OptParser.td

That file comes from llvm-lw-git, am building that fresh to verify everything is right with it.

frankyboy commented on 2019-04-07 16:47

[9/1654] Building Options.inc...

FAILED: include/clang/Driver/Options.inc

cd /home/compile/.cache/yay/clang-lw-git/src/llvm-project/clang/build && //bin/llvm-tblgen -gen-opt-parser-defs -I /home/compile/.cache/yay/clang-lw-git/src/llvm-project/clang/include/clang/Driver -I //include /home/compile/.cache/yay/clang-lw-git/src/llvm-project/clang/include/clang/Driver/Options.td -o include/clang/Driver/Options.inc -d include/clang/Driver/Options.inc.d

/home/compile/.cache/yay/clang-lw-git/src/llvm-project/clang/include/clang/Driver/Options.td:14:9: error: Could not find include file 'llvm/Option/OptParser.td' include "llvm/Option/OptParser.td"

got this error when trying to build package :) any tips Lone_Wolf?