Package Details: chromium-vaapi 74.0.3729.157-1

Git Clone URL: https://aur.archlinux.org/chromium-vaapi.git (read-only)
Package Base: chromium-vaapi
Description: Chromium with VA-API support to enable hardware acceleration
Upstream URL: https://www.chromium.org/Home
Keywords: browser web
Licenses: BSD
Conflicts: chromium
Provides: chromium
Submitter: samcv
Maintainer: OneObsession (maximbaz)
Last Packager: maximbaz
Votes: 66
Popularity: 3.220646
First Submitted: 2016-07-09 09:44
Last Updated: 2019-05-15 08:33

Dependencies (47)

Required by (44)

Sources (10)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

Foreigncon commented on 2019-01-02 09:52

@maximbaz https://github.com/chromium/chromium/commit/31225b9c5f3f685d65f742dc129241c30c32157c

clap22 commented on 2018-12-27 06:23

@digitalone Fix for executable name detection is coming soon upstream, the fix is in this series https://patchwork.freedesktop.org/series/49492/, I've been using it for a while

digitalone commented on 2018-12-14 21:18

Is someone able to explain me why

<driconf> <device screen="0" driver="radeonsi"> <application name="Chromium" executable="chromium"> <option name="allow_rgb10_configs" value="false" /> </application> </device> </driconf>

in /etc/drirc or $HOME/.drirc keeps playing reddish videos on chromium? What's wrong with that config?

enihcam commented on 2018-12-14 01:05

[1:15:1215/114722.869293:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.870482:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.871596:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.872317:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.873042:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.874713:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.875911:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.879423:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Failed to send video packet for decoding: timestamp=2419083 duration=41708 size=2625 side_data_size=0 is_key_frame=0 encrypted=0 discard_padding (us)=(0, 0)"} [1:15:1215/114722.879981:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.880920:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"video decoder reinitialization failed"} [1:15:1215/114722.881219:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:15:1215/114722.881533:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Format conversion failed."} [1:1:1215/114722.881941:ERROR:render_media_log.cc(30)] MediaEvent: PIPELINE_ERROR PIPELINE_ERROR_DECODE [2976:2983:1215/114729.391654:ERROR:socket_stream.cc(219)] Closing stream with result -2 [3006:3006:1215/114808.508607:ERROR:vaapi_wrapper.cc(1107)] Failed syncing surface VA error: internal decoding error [1:15:1215/114808.509896:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"video decode error"} [1:1:1215/114808.513472:ERROR:render_media_log.cc(30)] MediaEvent: PIPELINE_ERROR PIPELINE_ERROR_DECODE

Anyone?

VA-API driver is intel-media-driver. Disable Hardware Acceleration can workaround the issue.

clap22 commented on 2018-12-08 17:07

A couple of notes:

  • it builds with llvm8-svn again after last 2 releases failing as mentioned before
  • I had system crashes with jumbo build and ryzen hyperthreading enabled. It tried to use too much RAM and hangs. Doesn't happen if I disable SMT or jumbo build. I thought it was an unstable overclock at first but ended up consistently reproducing it @stock and underclocked.

maximbaz commented on 2018-12-08 14:38

Huh, interesting, you are right! Updated my post :P

ArchangeGabriel commented on 2018-12-08 14:27

@maximbaz: Only base-devel, not base. They are no assumption of any kind regarding base anywhere in Arch Linux. ;)

maximbaz commented on 2018-12-08 14:19

andrej: bison is part of base-devel group, and it is always assumed that base-devel group is installed when building AUR packages, check out this wiki page for more info.

andrej commented on 2018-12-08 09:58

I think that this package needs bison in its makedepends. Otherwise it tries to invokem bison and then fails quite early in the build process.

Foreigncon commented on 2018-12-07 12:38

@axfelix Actually, there used to be VaapiDrmPicture class only. This year they broke the class into several sub classes which look like:

  +-----------------+
  |   VaapiPicture  |
  +-----------------+
  ^                 ^
  | =vaapi-drm=     +----+ =xorg(vaapi-glx)=
  +--------------+       +------------------+
  | VaapiPicture |       | VaapiPictureTFP  |
  | NativePixmap |       | (This is default)|
  +--------------+       +------------------+
   ^   
   +-------------------------+
   |                         |
 +-------+               +-------+
 | VPNP  |               | VPNP  |
 | Ozone |               | Egl   |
 +-------+               +-------+

*VPNP is Vaapi Picture Native Pixmap. I believe somewhere these sub classes(esp. VPNP ozone) are not being included during building and this is what causes the error during linking. I may be wrong because when I see the source I can't find anything unusual. That's why I'm trying to build it with use_ozone=true ozone_platform_gbm=true use_intel_minigbm=true and use_egl=true to include the whole set of those drm classes. I am not confident with this anyway tbh.