Package Details: chromium-vaapi 75.0.3770.90-3

Git Clone URL: https://aur.archlinux.org/chromium-vaapi.git (read-only)
Package Base: chromium-vaapi
Description: Chromium with VA-API support to enable hardware acceleration
Upstream URL: https://www.chromium.org/Home
Keywords: browser web
Licenses: BSD
Conflicts: chromium
Provides: chromium
Submitter: samcv
Maintainer: OneObsession (maximbaz)
Last Packager: maximbaz
Votes: 71
Popularity: 6.156264
First Submitted: 2016-07-09 09:44
Last Updated: 2019-06-18 11:51

Dependencies (48)

Required by (47)

Sources (10)

guiodic commented on 2016-12-18 20:40

Arch Linux China has a Chromium 56 vaapi that works very well:

http://repo.archlinuxcn.org/x86_64/

But I can't find an update pkgbuild here https://github.com/archlinuxcn/repo

compgamer89 commented on 2016-12-18 06:59

@samcv Quick note about the 55.x build: Just tried it, and the build ended up choking on an re2/variadic_functions.h missing header. Looks like that header disappeared from the library this year (https://github.com/google/re2/commit/c5f0094d79032d53b4aace38580ac3d6d6f460fd#diff-374ae5ebecc7160d79d20964337e3c38), and Chromium is using an older version (~2015-12). Am retrying the build now without the system library override.

agm28011997 commented on 2016-12-17 04:40

I don't know if the sandbox is the problem for the hardware decoding in the amd gpu, but there is a patch here that i think can help with that problem, (or isnt it a patch?) https://codereview.chromium.org/1542013005/#ps1 if you can add the patch I can test if you want again, and the other packages gives me errores in compilation like before.. but chromium always fails me

samcv commented on 2016-12-16 22:43

https://cry.nu/files/chromium-vaapi-55.tar.gz
https://cry.nu/files/chromium-vaapi-55.tar.gz.sig

This is just the PKGBUILD and all other needed files to compile it. If somebody can test and make sure it works that would be great. I had issues getting 55 beta working right, but there are some new patches in there that the upstream Arch devs added for 55 so maybe it will work. Either comment back or send me an email to samantham@posteo.net. Thanks.

guiodic commented on 2016-12-16 09:36

Any news?

VerruckteFuchs commented on 2016-12-04 00:56

Chromium 55 is now in the Extra repo.

VerruckteFuchs commented on 2016-12-02 01:17

I use the pepper-flash package to get flash working in Chromium. It doesn't work in the currently available version of chromium-vaapi. When Chromium 55 comes out and you're ready to update chromium-vaapi it would be great if pepper-flash could work with it.

guiodic commented on 2016-11-21 20:09

@samcv

v53.x is pretty unusable now. A lor of websites don't work properly and also password storage doesn't work.
I'm using Firefox in the last weeks because that :(

xsmile commented on 2016-11-20 01:44

@samcv:

I would prefer a working 55, even if it is not yet in the stable channel.

Dheart commented on 2016-11-18 12:42

@olive, it builds on 16 GB, no problem. You can't build it in /tmp though unless you have 32GB, you'd need to clone the aur repo somewhere on your HDD and build it there. This is because /tmp uses half of your RAM by default and the chromium build requires about 12 gigs worth of files to be stored. This why installing it with yaourt would fail unless you have 32 gigs of RAM.

@samcv, go for the current v55