Package Details: chromedriver 90.0.4430.24-1

Git Clone URL: https://aur.archlinux.org/chromedriver.git (read-only, click to copy)
Package Base: chromedriver
Description: Standalone server that implements the W3C WebDriver standard (for google-chrome)
Upstream URL: https://chromedriver.chromium.org/
Licenses: BSD
Conflicts: chromium
Submitter: grimsock
Maintainer: jgwak
Last Packager: jgwak
Votes: 41
Popularity: 0.000419
First Submitted: 2011-11-28 18:45
Last Updated: 2021-05-06 18:58

Latest Comments

1 2 3 4 5 6 ... Next › Last »

bayes commented on 2021-06-30 19:11

Needs to be bumped to 91, which is now stable.

diff --git a/PKGBUILD b/PKGBUILD
index 4cbc5db..4244050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
 # Contributor: James An <james@jamesan.ca>
 # Contributor: lybin
 pkgname=chromedriver
-pkgver=90.0.4430.24
+pkgver=91.0.4472.101
 pkgrel=1
 pkgdesc="Standalone server that implements the W3C WebDriver standard (for google-chrome)"
 arch=('x86_64')
@@ -14,7 +14,7 @@ depends=(alsa-lib gtk3 libcups libxss libxtst nss xdg-utils)
 optdepends=(google-chrome)
 conflicts=(chromium)
 source=("${pkgname}_${pkgver}_linux64.zip::https://chromedriver.storage.googleapis.com/${pkgver}/${pkgname}_linux64.zip")
-sha512sums=('b85313de6abc1b44f26a0e12e20cb66657b840417f5ac6018946de0c8392b05c11d2c22d35f0526b26c35cf8d6134348e5b6c54a28a3955c5b22cc247ae2ce4a')
+sha512sums=('145fdc825a6ccd41583af4c54b9c384b0e21e68f19d20e9125b06cfc893577bfc0b4b331abf68882cad9f7948cd5339c2dc443345c9dceddb9328cf08811ab62')

jgwak commented on 2021-01-08 03:23

@jantman Please check chromedriver-beta package for latest release of chromedriver. This package follows stable release of chromedriver.

hawath commented on 2021-01-07 13:41

It seems that the sha512sum in PKGBUILD is not correct. I got "65f49dba91b71194b1cb7cf3c9660da04d5fb818ef56ee9bd7fc4e61dbbd2a05488dcba87aca6f7e167a5d6da5ca2e1fdb4c7c19e4a646e502bb57f7e0657b2a".

jgwak commented on 2020-07-15 10:21

@camb This seems to be a bug of gconf package. I reviewed the dependencies of this package and it seems like gconf is no longer necessary for this package. I updated the dependencies accordingly. This should fix your issue.

camb commented on 2020-07-10 09:22

Hi. Just tried to install and this is the tail of what got spat out on my terminal:

RefactoringTool: Files that were modified:
RefactoringTool: gsettings/gsettings-schema-convert
which: no gnome-autogen.sh in (/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/home/cyrilb/bin:/home/cyrilb/bin)
You need to install gnome-common from GNOME SVN and make
sure the gnome-autogen.sh script is in your $PATH.
==> ERROR: A failure occurred in prepare().
    Aborting...
:: Checking chromedriver integrity...
==> Making package: chromedriver 83.0.4103.39-1 (Fri 10 Jul 2020 10:16:19)
==> Retrieving sources...
  -> Found chromedriver_83.0.4103.39_linux64.zip
==> Validating source files with md5sums...
    chromedriver_83.0.4103.39_linux64.zip ... Passed
:: Preparing chromedriver...
==> Making package: chromedriver 83.0.4103.39-1 (Fri 10 Jul 2020 10:16:19)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Found chromedriver_83.0.4103.39_linux64.zip
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting chromedriver_83.0.4103.39_linux64.zip with bsdtar
==> Sources are ready.
:: failed to verify integrity or prepare gconf package```

Subsequently ran `pacaur -S gnome-common` which succeeded (guessing theres a dependency issue here) however then:
Checking for required M4 macros...
  introspection.m4 not found
***Error***: some autoconf macros required to build GConf
  were not found in your aclocal path, or some forbidden
  macros were found.  Perhaps you need to adjust your
  ACLOCAL_PATH?

==> ERROR: A failure occurred in prepare().
    Aborting...
:: Checking chromedriver integrity...
==> Making package: chromedriver 83.0.4103.39-1 (Fri 10 Jul 2020 10:21:42)
==> Retrieving sources...
  -> Found chromedriver_83.0.4103.39_linux64.zip
==> Validating source files with md5sums...
    chromedriver_83.0.4103.39_linux64.zip ... Passed
:: Preparing chromedriver...
==> Making package: chromedriver 83.0.4103.39-1 (Fri 10 Jul 2020 10:21:43)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Found chromedriver_83.0.4103.39_linux64.zip
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting chromedriver_83.0.4103.39_linux64.zip with bsdtar
==> Sources are ready.
:: failed to verify integrity or prepare gconf package

Any thoughts anyone?

(my apologies, I'm fighting markdown to make this readable)

jgwak commented on 2020-01-06 04:12

@flavius Sorry for the delay. For some reason, I didn't receive email notification of your comment and I just noticed it. I do have notification of this package enabled and I received an email notification of a comment from a different package a day after your comment, but I don't see your comment in my inbox. Anyways, I updated download link protocol from http to https. I didn't bump pkgrel since this change shouldn't affect the existing users of this package.

flavius commented on 2019-12-16 08:40

Could we change the download link from http to https?

We have an issue in our company with blocking http, which we cannot losen because of some strict security compliance criteria, but https works fine.

I would pretty much prefer not having to fork this package just for this, since it's just about adding an "s" which shouldn't break any one else's workflow.

Kind Regards, Flavius Aspra

gregdan3 commented on 2019-08-22 18:27

@fpqc Chromium installs its own chromedriver binary. If you install Chromium, you should not need this package. That said, likely the only reason it is marked incompatible is due to this package having a binary of the same name.

jgwak commented on 2019-06-05 18:41

@wshuman3 This package is not out-of-date. The latest stable release of chromedriver is still 74.0.3729.6 as of now1. If you want the latest beta version of chromedriver (75.0.3770.8), please install chromedriver-beta instead. Unflagging false out-of-date flag.

jgwak commented on 2019-02-27 20:25

@kageurufu I think your suggestions make perfect sense and I rolled back the version of this package to v72. I also submitted chromedriver-beta package to keep in sync with google-chrome-beta as well. Sorry for the hassles.