Package Details: chatty-beta 0.11b1-1

Git Clone URL: https://aur.archlinux.org/chatty-beta.git (read-only)
Package Base: chatty-beta
Description: Twitch Chat Client for Desktop
Upstream URL: https://chatty.github.io/
Licenses: GPL3
Conflicts: chatty
Provides: chatty
Submitter: Freso
Maintainer: Freso
Last Packager: Freso
Votes: 1
Popularity: 0.000370
First Submitted: 2018-07-18 19:29
Last Updated: 2019-10-28 23:20

Pinned Comments

Freso commented on 2019-07-06 13:13

Yes, JavaFX is required if you’re using OpenJDK; see https://wiki.archlinux.org/index.php/Java#OpenJDK – however, it is not given here as a dependency since theoretically other (non-OpenJDK) Java versions should not need it (and the non-OpenJDK packages I looked at don’t specify java-openjfx in their $provides). (I haven’t tested this though.)

This also means that only OpenJDK 8 will work for now, since the java-openjfx package is still only available in its Java 8 version: https://www.archlinux.org/packages/extra/x86_64/java-openjfx/ (flagged out of date more than a year ago). There’s a package in testing and AUR for Java 11 as well as one in AUR for Java 13, if you’re feeling adventurous.

Latest Comments

mheob commented on 2019-10-27 19:43

@Freso There is a new beta version of chatty.

Please commit this patch to update to version 0.11-b1: https://gist.github.com/mheob/e50f26584bc175a550c9fa0037ecfab9

Freso commented on 2019-07-06 13:13

Yes, JavaFX is required if you’re using OpenJDK; see https://wiki.archlinux.org/index.php/Java#OpenJDK – however, it is not given here as a dependency since theoretically other (non-OpenJDK) Java versions should not need it (and the non-OpenJDK packages I looked at don’t specify java-openjfx in their $provides). (I haven’t tested this though.)

This also means that only OpenJDK 8 will work for now, since the java-openjfx package is still only available in its Java 8 version: https://www.archlinux.org/packages/extra/x86_64/java-openjfx/ (flagged out of date more than a year ago). There’s a package in testing and AUR for Java 11 as well as one in AUR for Java 13, if you’re feeling adventurous.

zangoku commented on 2019-06-17 07:09

update is failing:

Building chatty-beta... ==> Making package: chatty-beta 0.9.7_b3-1 (Mon 17 Jun 2019 03:07:15 AM EDT) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found chatty-0.9.7-b3.tar.gz -> Found chatty.desktop -> Found chatty_script -> Found disable_version_check.patch ==> Validating source files with sha512sums... chatty-0.9.7-b3.tar.gz ... Passed chatty.desktop ... Passed chatty_script ... Passed disable_version_check.patch ... Passed ==> Removing existing $srcdir/ directory... ==> Extracting sources... -> Extracting chatty-0.9.7-b3.tar.gz with bsdtar ==> Starting prepare()... patching file src/chatty/Chatty.java Hunk #1 succeeded at 57 (offset -1 lines). ==> Removing existing $pkgdir/ directory... ==> Starting build()... /tmp/pamac-build/chatty-beta/src/chatty-0.9.7-b3/src/chatty/gui/components/completion/AutoCompletionWindow.java:30: error: package javafx.scene.control does not exist import javafx.scene.control.SelectionMode; ^ Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. 1 error

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':compileJava'.

    Compilation failed; see the compiler error output for details.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 1s ==> ERROR: A failure occurred in build(). Aborting...

Stebs commented on 2019-06-14 17:59

Build failed: .../chatty-beta/src/chatty-0.9.7-b3/src/chatty/gui/components/completion/AutoCompletionWindow.java:30: error: package javafx.scene.control does not exist import javafx.scene.control.SelectionMode;

$archlinux-java status

Available Java environments:

java-11-openjdk (default) java-8-openjdk

I also have java-openjfx installed

Build of 0.9.7_b1-1 was successful.

Update: Builds fine when setting the default to java-8-openjdk

Is the old Java 8 with JavaFX really indispensable for chatty?