Package Details: cfengine 3.10.4-1

Git Clone URL: https://aur.archlinux.org/cfengine.git (read-only, click to copy)
Package Base: cfengine
Description: Automated suite of programs for configuring and maintaining Unix-like computers.
Upstream URL: http://www.cfengine.org
Licenses: GPL3
Submitter: None
Maintainer: ektich
Last Packager: ektich
Votes: 19
Popularity: 0.000000
First Submitted: 2008-10-25 17:55
Last Updated: 2018-05-11 16:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

andreas_baumann commented on 2012-10-20 20:03

updated to 3.3.8, new dependency libvirt

andreas_baumann commented on 2012-06-02 07:47

updated to 3.3.3

andreas_baumann commented on 2012-05-16 08:17

updated to 3.3.1

andreas_baumann commented on 2012-04-11 15:40

updated to 3.3.0

fukawi2 commented on 2011-10-29 09:15

Update to 3.2.3

Thanks andreas_baumann, I've updated the note about deps, and the source URL did change slightly ('source_code' became 'source-code')

andreas_baumann commented on 2011-10-29 08:52

source=("http://cfengine.com/source-code/download?file=${pkgname}-${pkgver}.tar.gz")

actually works fine. I was wrong here.

andreas_baumann commented on 2011-10-27 03:40

Tried 3.2.3, compiles.

There are some issues:

The advice to comment out configure options could trouble newbies with messages like:

/media/sd/arch/adapted_packages/cfengine/PKGBUILD: line 33: --with-postgresql: command not found

Better would IMHO be to just add a comment there and not a message: Arch users
should feel comfortable to edit PKGBUILD files anyway.

The source can't be downloaded, but that's a cfengine policy for the community edition. Maybe
here a message would be appropriate and setting the source value in the PKGBUILD as follows:

source=("${pkgname}-${pkgver}.tar.gz")

Just an idea. :-)

fukawi2 commented on 2011-09-11 02:28

Urgh, sorry... Blonde moment. Fixed.

andreas_baumann commented on 2011-09-10 08:09

I think 'libmysqlclient' is enough, no need to have the full server as dependency..

fukawi2 commented on 2011-09-09 08:20

Bump to 3.2.0; Thanks andreas_baumann

libpromises.so seems to depend on the mysql/postgres libs if you compile with those options, so I've added them as a dep rather than optdep