Package Details: ceres-solver 2.0.0-1

Git Clone URL: https://aur.archlinux.org/ceres-solver.git (read-only, click to copy)
Package Base: ceres-solver
Description: Solver for nonlinear least squares problems
Upstream URL: http://ceres-solver.org/
Licenses: LGPL
Submitter: dtag
Maintainer: dtag
Last Packager: dtag
Votes: 17
Popularity: 0.028664
First Submitted: 2015-11-27 09:36
Last Updated: 2020-11-02 14:15

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

xantares commented on 2019-07-01 09:02

hi, I dont think openmp dependency is needed, that's the llvm variant, whereas we build with gcc here

xantares commented on 2019-06-24 17:33

no need to bump the build number, this triggers unnecessary rebuilds as the package content did not change

dtag commented on 2019-06-19 12:34

@xantares: Thank you. I've Added those flags.

xantares commented on 2019-06-19 10:04

hi, you can avoid to build examples with: -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF

dtag commented on 2019-04-26 11:30

Hi @xantares, Makes sense; I've made the changes you suggested.

xantares commented on 2019-04-25 08:29

hi,

linux packages ship shared libs, here the static lib is provided instead,

could you add -DBUILD_SHARED_LIBS=ON cmake option ?

also 'gcc-libs' in makedepends is useless

xan.

dtag commented on 2016-12-18 17:29

@maggeych: Done.

maggeych commented on 2016-12-17 17:40

This needs an update to version 1.12.
Version 1.11 fails to build against the latest eigen3.

dtag commented on 2016-10-30 15:33

@arcnmx: I have gflags installed and I am not getting any errors. Can you elaborate on what the issue is?

arcnmx commented on 2016-10-28 19:02

Fails to build if the gflags package is installed on the system.