Package Details: cava 0.7.2-2

Git Clone URL: https://aur.archlinux.org/cava.git (read-only, click to copy)
Package Base: cava
Description: Console-based Audio Visualizer for Alsa
Upstream URL: https://github.com/karlstav/cava
Licenses: MIT
Submitter: CelestialWalrus
Maintainer: funilrys
Last Packager: funilrys
Votes: 93
Popularity: 2.72
First Submitted: 2015-05-05 22:15
Last Updated: 2020-09-15 19:40

Latest Comments

« First ‹ Previous 1 2 3

Brottweiler commented on 2017-01-04 14:44

==> WARNING: Package contains reference to $srcdir

apolih commented on 2016-11-29 18:03

cava is not working for me after install:

$ cava
mkdir: cannot create directory ‘/usr/bin/.libs’: Permission denied
/usr/bin/ld: cannot open output file /usr/bin/.libs/10890-lt-cava: No such file or directory
collect2: error: ld returned 1 exit status

Perhaps related to this warning during the build?

$ makepkg

...

==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issue...
==> WARNING: Package contains reference to $srcdir
==> Creating package "cava"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: cava 0.4.2-1 (Tue Nov 29 11:58:22 CST 2016)

hillz commented on 2016-11-17 12:20

For those having problem where the visualizer doesn't start after you play a song, change autosens to 0 and sensitivity to 10, don't forget to uncomment those options

Anonymous comment on 2015-11-29 04:47

updated pkgbuild, https://gist.github.com/shaggytwodope/73dbe7a98fb860d2af77

tho can prolly do without --prefix bit... but yeah lazy.

addisonamiri commented on 2015-11-19 19:32

Awesome! Build works perfectly.

CelestialWalrus commented on 2015-11-19 19:11

Got some time & updated this ;-)

Thanks shaggy.

addisonamiri commented on 2015-11-05 03:09

I'm getting build errors. Unfortunately I don't know enough about ncurses to figure out what's going on. Here's the output: http://pastebin.com/apMSvuui

Anonymous comment on 2015-09-20 02:47

Until adjusted upstream, needs a little tweak to compile against current ncurses.

under build function add:

sed -i -e 's/ncursesw5-config/ncursesw6-config/' makefile

before the make call

karlstav commented on 2015-09-19 10:09

hi alex,

I just pushed 0.3.5 yesterday.

Recently made the move to arch, so maybe I can take over the maintenance of this. Not 100% sure how things work around here, but I'll figure it out.