Package Details: catalyst 15.9-20

Git Clone URL: https://aur.archlinux.org/catalyst.git (read-only, click to copy)
Package Base: catalyst
Description: AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst-test
Submitter: wonder
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 328
Popularity: 0.000000
First Submitted: 2009-08-09 08:02
Last Updated: 2018-04-29 16:26

Required by (3)

Sources (23)

Inkaine commented on 2010-04-29 18:27

==> Validating source files with md5sums...
ati-driver-installer-10-4-x86.x86_64.run ... FAILED
catalyst.sh ... Passed
amdcccle.desktop ... Passed
atieventsd.sh ... Passed
fglrx-2.6.33.patch ... Passed
fglrx-2.6.34-rc4.patch ... Passed
==> ERROR: One or more files did not pass the validity check!

I'm getting a different md5 sum (e5a2343e2a6a8ea2fedd272a97fcadcc) on the driver file, even after redownloading a second time. The file probably changed again after yesterday's upload since it's also giving me the date Apr 29th 2010 19:08.

Vi0L0 commented on 2010-04-29 00:07

[xorg18] has been moved to [testing] :/

Vi0L0 commented on 2010-04-28 23:14

[catalyst] repo (now with xorg-server 1.7) has been updated, fresh [catalyst-xorg18] repo has arrived, [catalyst-test-xorg18] repo got different address now.
More here: http://bbs.archlinux.org/viewtopic.php?pid=750810#p750810

Vi0L0 commented on 2010-04-28 20:09

Thanks agapito
Updated.
Not much change between this and catalyst-test...
xserver 1.7 support, and patched xserver 1.8 support.
Version of 2d driver = 8.72.5
Version of opengl lib = 3.2.9756
For kernel newer than 2.6.32 we still need to use (included) patches.
Works also with 2.6.34-rc5

agapito commented on 2010-04-28 18:32

10.4 released

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_104_linux.pdf

Vi0L0 commented on 2010-04-28 13:01

@kullfar: catalyst 10.4 should support xserver 1.7
plus there is a package called catalyst-test http://aur.archlinux.org/packages.php?ID=34773 which supports xserver 1.7
There is also a repo with catalyst-test and patched for it xserver 1.8 which works pretty nice, read here: http://bbs.archlinux.org/viewtopic.php?pid=740353#p740353

Vi0L0 commented on 2010-04-28 11:57

@kullfar: catalyst 10.4 should support xserver 1.7
plus there is a package called catalyst-test http://aur.archlinux.org/packages.php?ID=34773 which supports xserver 1.7
There is also a repo with catalyst-test and patched for it xserver 1.8 with works pretty nice, read here: http://bbs.archlinux.org/viewtopic.php?pid=740353#p740353

kullfar commented on 2010-04-28 05:41

xorg 1.8 is coming.
the worsest thing, that can happens - xorg 18 in extra before catalyst supporting xorg 17...
any news on xorg 1.7 support?

Vi0L0 commented on 2010-04-13 11:18

Yes, both !radeon in MODULES and nomodeset in menu.lst got same effect. Although i believe nomodeset is more appropriate way.

Vi0L0 commented on 2010-04-13 11:10

Yes, both !radeon in MODULES and nomodeset in menu.lst got same effect.