Package Details: catalyst 15.9-20

Git Clone URL: https://aur.archlinux.org/catalyst.git (read-only, click to copy)
Package Base: catalyst
Description: AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst-test
Submitter: wonder
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 330
Popularity: 0.000000
First Submitted: 2009-08-09 08:02
Last Updated: 2018-04-29 16:26

Dependencies (7)

Required by (3)

Sources (23)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

Vi0L0 commented on 2015-06-04 13:23

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- i've added initial support for 4.1 kernel (using kolasa's patch, tested on 4.1rc5)
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx

Vi0L0 commented on 2015-05-04 19:36

14.12-3:
- 4.0 kernel support (thanks to kolasa for patch)

Vi0L0 commented on 2015-03-08 14:06

14.12-2:
- using kolasa's patch to cover 3.19 kernel support

optomus commented on 2015-01-29 23:30

I tired to install today after running pacman -Syu, which brought down linux-3.18.4-1. This threw an error "make *** /usr/lib/modules/3.18.2-2-ARCH cannot be found: Directory or file does not exist" (or something like that). I believe the kernel has been updated to 3.18.4-1-ARCH though this (PKGBUILD?) is expecting 3.18.2-2-ARCH.
To get around this problem until an update is produced run:
sudo mv /usr/lib/modules/3.18.4-1-ARCH /usr/lib/modules/3.18.2-2-ARCH
Then install with "yaourt -S catalyst" and before rebooting run:
sudo mv /usr/lib/modules/3.18.2-2-ARCH /usr/lib/modules/3.18.4-1-ARCH
Otherwise your kernel will fail to load.

Vi0L0 commented on 2014-12-09 08:00

Uuuuu finaly same new release.
Im afk and should be back tomorrows evening, then I should be able to test and update

Vi0L0 commented on 2014-12-09 07:59

Uuuuu finaly same new release.
Im afk and should be back tomorrows evening.

Vi0L0 commented on 2014-10-03 22:33

don't look at the amd's versioning, it's pure craziness ;P.
I'm always versioning in a old-fasion way "year.month" to keep pacman sane - theres only one problem with it - whenever amd decide to put two separate versions in a same month, where newer is actually worse/older...
catalyst-test brings beta driver which was prepared for ubuntu 14.10 to support xserver 1.16.
And this stable driver, versioned by amd as 14.9, is just another mile-stone - probably old because getting certification from microsoft is taking some time (remember that catalyst shares code between linux and windows). And it doesn't support xserver 1.16 - but its working, amd marked is as stable, and so am I

GreenRaccoon23 commented on 2014-10-03 22:19

Right now, this one is newer than the catalyst-test package, right? Looking at the pkgbuild's, this one is version 14.301.1001 and catalyst-test is 14.201. I'm just a little confused why the catalyst-test package supports xserver 1.17 and this one doesn't.

Vi0L0 commented on 2014-10-03 20:54

updated to 14.9-1:
- official, stable release
http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-9LINReleaseNotes.aspx

- it doesn't support xserver 1.16

- I added my fresh patch for kernel 3.17 rc6.
Notes about the patch:
1. it probably wont work on 3.17 kernels older than rc6 because I don't know how to tell preprocessor about rc version :P
2. im unable to test resume/suspend
3. im not the developer, just pressing random keys :P so the patch could be less/more noobish :-)

Vi0L0 commented on 2014-10-03 19:56

well yes, catalyst-test @AUR or packages from [catalyst] are basing on driver for ubuntu 14.10 and does support xserver 1.16.

Its just that official and stable AMD's 14.9 doesn't support xserv 1.16.