Package Details: catalyst 15.9-20

Git Clone URL: https://aur.archlinux.org/catalyst.git (read-only, click to copy)
Package Base: catalyst
Description: AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst-test
Submitter: wonder
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 331
Popularity: 0.000001
First Submitted: 2009-08-09 08:02
Last Updated: 2018-04-29 16:26

Dependencies (7)

Required by (3)

Sources (23)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Vi0L0 commented on 2016-01-20 14:26

15.9-9:
- added 4.4 kernel support

Vi0L0 commented on 2016-01-04 18:27

I don't like this dirty, kinda 'illegal', patch and that's why I was always trying to avoid it, but yes - sometimes it has to be applied.
I will change it in the next update (which should also bring 4.4 support), it should happen within days.

nous commented on 2016-01-04 17:53

I'm using catalyst-hook-15.12 from the [catalyst] repo. Trying to build the fglrx module in an older LTS kernel (x86_64, latest 3.14.58-lts), I'm getting the following:

LD [M] /tmp/catalyst.PWoUZ4/fglrx.o
Building modules, stage 2.
MODPOST 1 modules
FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'task_nice'
/usr/lib/modules/3.14.58-pf-lts/build/scripts/Makefile.modpost:90: recipe for target '__modpost' failed
make[1]: *** [__modpost] Error 1
Makefile:1281: recipe for target 'modules' failed
make: *** [modules] Error 2

Please, remove the $CARCH before the fglrx_gpl_symbol.patch:
test "${CARCH}" = "i686" && patch -Np1 -i ../fglrx_gpl_symbol.patch

Same error also with catalyst-hook 15.9 from [catalyst-stable]. Manually applying the patch allows modpost to succeed in 64bit machines. Thanks.

Vi0L0 commented on 2015-12-22 08:22

This message comes on catalyst >= 15.11. For now its available only on catalyst-test@AUR and [catalyst] repo

15.9 officially supports 5 and 6 k. [catalyst-stable] repo and most AUR packages still contains it. It will be updated in some future (maybe month) and then special legacy repo will arrive.

Markismus commented on 2015-12-21 13:51

I got this message:

------------ DROPPED SUPPORT FOR RADEONS HD 5 6 k --------------
Please note that this release SADLY :( is
dropping support for pre-GCN cards so mainly
Radeons of series 5000 and 6000
----------------------------------------------------------------

What could I try to install catalyst on a 5k card with kernel 4.2?

Vi0L0 commented on 2015-12-13 19:55

15.9-8:
just like commit says:
- adding new patch from crimson
- removing gcc49 dependency
- adding initial grsec kernel support

should be safe to remove gcc49 pkg :)

Vi0L0 commented on 2015-10-28 18:45

catalyst-test now supports 4.2 kernel. You have to install gcc49, thought.
Feel free to test and give feedback - especially if your system is i686 or when its not working.

https://aur.archlinux.org/packages/catalyst-test

mouseman commented on 2015-10-25 19:54

Thanks for the Gnome fix!

Vi0L0 commented on 2015-10-23 08:25

It would be most easy for you if you would use catalyst-test from AUR or [catalyst] repository. Look at instalation and configuration on wiki, it should be simple:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Installing_the_driver

catalyst doesn't support 4.2 kernel, so boot your system from linux-lts (configure the bootloader to use it).

Also since you are using gnome 3.18 read my comment below and use my patched cogl package

herycp commented on 2015-10-23 07:34

im use notebook:
a8 4500
radeon 7640g + 7470m

Sistem :
kernel 4.2.3-1 + lts
gnome 3.18
gdm

is save if im install it??
or must from unofficial??
need configure?