Package Details: catalyst-total 15.9-25

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only, click to copy)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd
Provides: catalyst=15.9, catalyst-hook=15.9, catalyst-libgl=15.9, catalyst-utils=15.9, dri, libatical=15.9, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.9, opencl-driver
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 129
Popularity: 0.000000
First Submitted: 2009-11-11 05:59
Last Updated: 2018-04-29 16:39

Dependencies (23)

Required by (907)

Sources (36)

niqingliang2003 commented on 2011-08-05 13:15

new problem:
when start Virtualbox, I got that:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libGL.so.1: cannot open shared object file: No such file or directory

why the Virtualbox can't find the /usr/lib/catalystpxp/libGL.so.1 ????

niqingliang2003 commented on 2011-08-01 02:30

@ViOLO:
thanks, after remove libgl, the gnome returns normal (except the rainbow problem).
I have the same problem as endlessroad1991 when sudo amdcccle.

niqingliang2003 commented on 2011-08-01 02:23

@ViOLO:
thanks

Vi0L0 commented on 2011-07-29 18:14

@niqingliang2003:
yes, i can observe same behaviour whenever libgl (+ deps like xf86-video-ati) is present together with catalyst on the system.

Guess that paths to the libs are hardcoded and if libgl+xf86-video-ati packages are present then gnome3 will take it rather than those placed in /usr/lib/catalystpxp even if ld.conf is telling it to do otherwise.

I don't have time to look closer but guess that a fix will be to compile gnome3 whit some configure options/changing some source line. If someone will figure it out please share.
+ easy way is ofcourse to remove libgl+xf86-video-ati packages...

niqingliang2003 commented on 2011-07-29 09:05

does anyone can help me ????

niqingliang2003 commented on 2011-07-29 08:08

I have a new pc DELL optiplex 990 with ati 5450 installed archlinux using archboot. when start gdm, after login, I can only see the wallpaper and mouse.
the ~/.xsession-errors has a sentence:

(gnome-shell:20642): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context
Window manager error: Unable to initialize Clutter.
Failure: Module initalization failed
Failed to play sound: File or data not found

after change the driver to xf86-video-ati, I can use gnome3 in fallback mode, no 3d acceleration.

after google, I found something like: (rpath in gnome-shell)
https://bugzilla.redhat.com/show_bug.cgi?id=716572

niqingliang2003 commented on 2011-07-29 07:48

I have a new pc DELL optiplex 990 with ati 5450 installed archlinux using archboot. when start gdm, after login, I can only see the wallpaper and mouse.
the ~/.xsession-errors has a sentence:

(gnome-shell:20642): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context
Window manager error: Unable to initialize Clutter.
Failure: Module initalization failed
Failed to play sound: File or data not found

after change the driver to xf86-video-ati, I can use gnome3 in fallback mode, no 3d acceleration.

niqingliang2003 commented on 2011-07-29 03:38

I have a new pc DELL optiplex 990 with ati 5450 installed archlinux using archboot. when start gdm, after login, I can only see the wallpaper and mouse.
the ~/.xsession-errors has a sentence:"unable to find suitable fbconfig for the GLX context"

after change the driver to xf86-video-ati, I can use gnome3 in fallback mode, no 3d acceleration.

niqingliang2003 commented on 2011-07-29 03:20

I have a new pc DELL optiplex 990 with ati 5450 installed archlinux using archboot. when start gdm, after login, I can only see the wallpaper and mouse.
the ~/.xsession-errors has a sentence:"unable to find suitable fbconfig for the GLX context"

after change the driver to xf86-video-ati, I can use gnome3 in fallback mode, no 3d acceleration.

Anonymous comment on 2011-07-23 17:23

Latest mkinitcpio reports a warning with your hook :
"==> WARNING: Hook 'fglrx' uses a deprecated 'install' function. This should be renamed 'build'"