Package Details: catalyst-total 15.9-25

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only, click to copy)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd
Provides: catalyst=15.9, catalyst-hook=15.9, catalyst-libgl=15.9, catalyst-utils=15.9, dri, libatical=15.9, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.9, opencl-driver
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 129
Popularity: 0.000000
First Submitted: 2009-11-11 05:59
Last Updated: 2018-04-29 16:39

Dependencies (23)

Required by (907)

Sources (36)

Vi0L0 commented on 2011-10-12 19:15

im not using packer, but it does look like a packer error for me because xf86-input-evdev 2.6.0-3 from [xorg110] conflicts with xorg-server<1.10.0.
Be sure that you have placed [xorg110] repo above ALL other repos in pacman.conf, and if packer will still see things that do not exist - use pacman :)

securitybreach commented on 2011-10-12 17:36

So after setting up the xorg110 repo, I get the following error when running packer -Syu:

:: xf86-input-evdev and xorg-server are in conflict (xorg-server<1.10.99.902). Remove xorg-server? [y/N] y


Any ideas on how to get around this and also is there is fix being worked on or do we have to wait on ATI to provide it?

Vi0L0 commented on 2011-10-12 15:39

catalyst isn't working with fresh xorg-server 1.11
use [xorg110] repo: https://wiki.archlinux.org/index.php/ATI_Catalyst#Xorg-server_repositories

Anonymous comment on 2011-10-12 11:54

:: catalyst-total: requires xorg-server<1.11.0

Deusdies commented on 2011-09-30 05:53

Downgrading to 11.8 as well. I had contstant random xorg crashes with 11.9. ATI, is it MAYBE possible that you release drivers that do fix a thing, but don't break another thing?!

Vi0L0 commented on 2011-09-29 18:25

although without pxp support

Vi0L0 commented on 2011-09-29 18:25

11.9 sux ;P
downgraded to 11.8 :)

Vi0L0 commented on 2011-09-28 16:38

updated to 11.9

haaah - i don't see rainbow bar in GNOME3 although other bad things stayed, like slow window moving or strange flickering/garbages rendered whenever i will run kde app with systray icon...

_odd thing_ - the URL has changed - was: ati-driver-installer-11-9-x86.x86_64.run , is ati-driver-installer-11.9.x86.x86_64.run, so - is now . in version, i actually found this 11.9 driver because of misstype :) LOL


pxp support has been REMOVED cuz im unable to do this ;(

Vi0L0 commented on 2011-09-28 15:46

this will be updated to 11.9 as soon as i will remove powerXpress support from it

Vi0L0 commented on 2011-09-23 17:54

@izza:
biggest issue: it would be hard to mainatin after some time - i mean all those kernel' patches that i would have to test on all catalyst's versions...
Also this would generate very big (and hard to read) PKGBUILD after some time - so this would brake KISS rule i guess. Is there any package in AUR with "version choosing" functionality?

+ there is catalyst' archive of used PKGBUILD's here: http://catalyst.apocalypsus.net/tarball/