Package Details: catalyst-hook 15.9-20

Git Clone URL: https://aur.archlinux.org/catalyst-hook.git (read-only, click to copy)
Package Base: catalyst-hook
Description: AMD/ATI drivers. Auto re-compile fglrx module while shutdown/reboot.
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-test
Provides: catalyst=15.9
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 95
Popularity: 0.000000
First Submitted: 2010-09-15 17:45
Last Updated: 2018-04-29 16:33

Dependencies (9)

Required by (3)

Sources (26)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

FuckNewArch commented on 2020-06-06 11:31

For anyone wondering here's an archive of the linux<4.11 kernel and headers: http://mirror.mozy.com/archlinux/core/os/x86_64/

The official Arch archive no longer has them.

sudo pacman -U linux-4.10.13-1-x86_64.pkg.tar.xz linux-headers-4.10.13-1-x86_64.pkg.tar.xz --overwrite "* will force a downgrade, once you've downloaded all of those packages.

Add IgnorePkg = linux linux-headers to your /etc/pacman.conf to prevent upgrades.

And look into hardening your kernel, because it's way out of date.

FuckNewArch commented on 2020-06-06 11:17

@nabster

pacman -Syyu --overwrite '*'

for any 'exists in filesystem from wayland'

@Vi0L0

Thank you for your work.

nabster commented on 2019-01-06 02:08

Hello, also /usr/lib/libwayland-egl.so from mesa-noglvnd exists in filesystem from wayland (and this doesn't seem safe to remove?)

nabster commented on 2019-01-06 01:59

Hi, could this possibly be updated to work with the kernel in the current Arch Release, linux 4.20.0? Thank you for your work on these drivers.

Vi0L0 commented on 2018-11-12 17:39

It's because you don't have linux package installed, I guess. This package was once missing linux dependency but it was added because users wanted it. Linux dependency is more like informational, to give you info about supported kernel version, you can just remove it from PKGBUILD if you want.

netrunn3r commented on 2018-11-06 15:21

Hi! I have problem with installing catalyst-hook from repo:

pacman -S catalyst-hook (and other catalyst-*)

warning: cannot resolve "linux<4.17", a dependency of "catalyst-hook"

But my kernel is 4.14:

$ uname -a

Linux *** 4.14.79-1-lts #1 SMP Sun Nov 4 16:35:49 CET 2018 x86_64 GNU/Linux

$ pacman -Qi linux

error: package 'linux' was not found

$ pacman -Qi linux-lts | grep Version

Version : 4.14.79-1

I did above after fresh reboot. If I want to install catalyst-dkms or catalyst-generator, I have the same problem.

Vi0L0 commented on 2017-04-03 13:32

package dependency is rather clear: linux<4.11
package comes with patches for 4.10 kernel. It should work fine, not sure about switchable graphics thought - it has been long time since I saw note on this topic.

Also, if you are already using dkms it could be better to use catalyst-dkms package instead of this one.

Just be sure to switch from mesa to mesa-noglvnd, or use [catalyst]/[catalyst-stable] repo, beacuse libglvnd patches have broken catalyst's support.

doria90 commented on 2017-04-03 13:17

Hi!
New to Arch, been using Antergos to make the transition easy.
I've been trying to get my Radeon HD 8x switchable graphics card to work but it appears that the kernel is at 4.10 while the package is limited to < 4.7.
Is there anything I can do to make this work?

Vi0L0 commented on 2016-10-03 18:52

it is, but it's domain name has changed, was mirror.hactar.bz, is mirror.hactar.xyz

simplykaka commented on 2016-10-03 15:21

Is the mirror(http://mirror.hactar.bz/Vi0L0/catalyst/$arch) working?