Package Details: catalyst-firepro 15.302.2301-5

Git Clone URL: https://aur.archlinux.org/catalyst-firepro.git (read-only)
Package Base: catalyst-firepro
Description: AMD/ATI drivers for FirePro/GL/MV brand cards. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport.
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-control, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd
Provides: catalyst=15.302.2301, catalyst-dkms=15.302.2301, catalyst-libgl=15.302.2301, catalyst-utils=15.302.2301, dri, libatical=15.302.2301, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.302.2301, opencl-driver
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 6
Popularity: 0.000000
First Submitted: 2011-01-25 17:19
Last Updated: 2017-04-03 19:13

Dependencies (23)

Required by (817)

Sources (28)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

Vi0L0 commented on 2014-04-28 21:19

updated to 13.35.1012

Thanks for the head up JSpaces.

I built it totally atop of the catalyst-test package, no changes except for the name and versioning

Though I wasn't able to run it on xserver 1.15, were you JSpaces?
If yes then I will check your patch.

Works well on xserver 1.14 here on r9 290x, even without not supported hardware watermark.

I picked up catalyst-test because its last release is fixing symlinks and adding pxp support, which can be also used to switch between catalyst and oss ati without the need of installing/removing packages, while not messing with the system.

Symlinks of the package were modified to better suit to the mesa standard and fixed, unfortunatelly it caused a little problem, but simple - If you will see something like:
/usr/lib32/libAMDXvBA.so.1 exists in filesystem
/usr/lib32/libXvBAW.so.1 exists in filesystem
/usr/lib32/libatiuki.so.1 exists in filesystem

there are three ways to fix it, every single one should work:
1st method:
if there's no more file conflicts you can use:
pacman -U --force
2nd method:
is to remove and install again lib32-catalyst-utils package
3rd method:
is to remove conflicting files manually, and then update

JSpaces commented on 2014-04-28 00:23

The latest catalyst-firepro version is 13.35.1012. Unfortunately the gentoo_linux-3.10 patch no longer works. I was able to get the fglrx module to successfully build by creating a diff with kolasa's fglrx-13.350 version of firepro_public.c (from https://github.com/kolasa) and the one in the 13.35.1012 along with some patches from the regular latest catalyst package.
The list of patches that function are:
catalyst_build_module
hook-fglrx
catalyst.conf
atieventsd.service
catalyst-hook.service
arch_3.13_kernel_acpi_node.patch
atieventsd.sh
ati_make.sh
catalyst.sh
lib32-catalyst.sh
makefile_compat.patch
arch-fglrx-authatieventsd.patch
firegl_public.patch
lano1106_fglrx_intel_iommu.patch
lano1106_kcl_agp_13_4.patch
temp_links_catalyst
temp-links-catalyst.service
cold-fglrx-3.14-current_euid.patch
Here is the link to the firepro_public.patch:
http://pastebin.com/WCLsvri6
(note: expires in 30 days)
PKGBUILD patch line:
patch -Np0 -i ../firegl_public.patch
Xorg starts and no errors are present in Xorg.0.log.

Jonhoo commented on 2014-03-28 15:25

FYI: catalyst-test@AUR works perfectly fine with the FirePro V4900 (don't know about others) including OpenCL and X 1.15.

Jonhoo commented on 2014-03-28 15:02

Phoronix claimed[1] a long time ago that the regular Catalyst drivers work fine with the FirePro-series graphics cards. Can anyone confirm whether this is still the case, and if so, whether there is any performance penalty to doing so?

Would be nice to be able to upgrade to X 1.15 already...

[1]: http://www.phoronix.com/scan.php?page=article&item=amd_firepro_open&num=1

Vi0L0 commented on 2014-02-23 17:45

@JSpaces:
ah yes, thanks and sorry for the delay.
I also added:
- authatieventsd' patch by solar (patch s/-1/255)
- 'lib32-libxinerama' to the deps (thanks sas)

JSpaces commented on 2014-02-23 01:37

@Vi0l0
The arch_3.13_kernel_acpi_node.patch from the regular catalyst package with the latest linux kernel/headers 3.13.4 works on this package as well. X-windows started and runs. No errors were detected in Xorg.0.log file.

Vi0L0 commented on 2013-11-18 20:11

silent update, no pkgrel bump:
- thanks to zoopp and his referer we no longer have to download installer manually :)

Vi0L0 commented on 2013-11-17 20:51

13.152.4-2:
- added symlink as sugested by lano1106:
/usr/lib32/libXvBAW.so -> libXvBAW.so.1.0

Vi0L0 commented on 2013-11-13 18:00

updated to 13.152.4-1:
- xserver 1.14 support
- works like catalyst 13.6

As you can see on the top of PKGBUILD:
NOTE: before building please download 13.152.4-linux-130928a-163383c-retail.zip using this site:
http://support.amd.com/en-us/download/workstation?os=Linux%20x86_64
and move it next to this PKGBUILD


@JSpaces: thanks for the head upa nd all the infos! :)
As you can see i decided to use modified (to work with catalyst 13.6) gentoo patch for 3.10 kernel - gentoo patch was always working best on the /proc here

JSpaces commented on 2013-11-13 01:21

@Vi0L0 Below are links to Kolasa latest derived patches that allow the fglrx module to complete successfully and run with xorg 13. The current "kolasa_fglrx_3.10.patch" fails on the module creation. The "kolasa_fglrx_fixing_ttys.patch" is no longer required as the code base has been updated. Makepkg will automatically unzip zip files with bsdtar so unzip is no longer required at all.
The driver has a new include folder: /usr/include/ATI/GL
install -d ${pkgdir}/usr/include/ATI/GL
install -m644 usr/include/ATI/GL/*.h ${pkgdir}/usr/include/ATI/GL
Everything else appears to be the same structure.

Original file: https://github.com/kolasa/fglrx-13.101/blob/ae7de2751be17484bc98d82e1c1901e5d432e430/drm_proc.h
Title: kolasa_drm_proc.patch
http://pastebay.com/1349794

Original file: https://github.com/kolasa/fglrx-13.101/blob/ae7de2751be17484bc98d82e1c1901e5d432e430/firegl_public.c
Title: kolasa_firegl_public.patch
http://pastebay.com/1349800

Latest blob link:
http://www2.ati.com/drivers/firepro/13.152.4-linux-130928a-163383c-retail.zip