Package Details: catalyst-firepro 15.302.2301-5

Git Clone URL: https://aur.archlinux.org/catalyst-firepro.git (read-only)
Package Base: catalyst-firepro
Description: AMD/ATI drivers for FirePro/GL/MV brand cards. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport.
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-control, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd
Provides: catalyst=15.302.2301, catalyst-dkms=15.302.2301, catalyst-libgl=15.302.2301, catalyst-utils=15.302.2301, dri, libatical=15.302.2301, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.302.2301, opencl-driver
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 6
Popularity: 0.000000
First Submitted: 2011-01-25 17:19
Last Updated: 2017-04-03 19:13

Dependencies (23)

Required by (818)

Sources (28)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Vi0L0 commented on 2015-12-26 21:34

Packages are pretty old, from stable repos ie:
gnome-shell 3.18.3-1
gdm 3.18.2-1
clutter 1.24.2-1

Malekeith commented on 2015-12-26 20:59

I've tried a fresh arch installation with Gnome running "gdm 3.18.2-1" and "wayland 1.9.0-1". I'm still currently unsure to why I can't boot up GDM login screen.

Vi0L0, what was the version of GNOME that you tested on ? I tried disabling wayland, and defaulted back to xorg, it got the login screen working, but after logging in it hangs at a grey screen which will not fade away.

EDIT : "ctrl + alt + f2 / f1" skipped the grey screen and made most of GNOMEs, functionality work but at a cost of my gfx getting quite toasty

Vi0L0 commented on 2015-12-25 15:57

No, leave it as is, it's perfectly fine. Just wanted to confirm you have it installed.

Malekeith commented on 2015-12-25 15:53

I'm currently using the one you linked in the comments, should I remove ?

Vi0L0 commented on 2015-12-25 15:19

But you are using patched cogl package (available ie in the [catalyst] repo)? Just checking

Malekeith commented on 2015-12-25 13:31

it works quite fine for the most part, aticonfig --initial and fglrxinfo works fine too. Since, my W8100 got detected

fglrxinfo:
http://pastebin.com/FLdgU2cD

aticonfig --initial:
http://pastebin.com/zAhRt0Ey

xorg:
http://pastebin.com/AEqabEKz

I added "nomodeset" on the bootloader side, and by default using aticonfig made the "/etc/modules-load.d/catalyst.conf" which has "fglrx"

Practically followed the instructions from the wikipage :https://wiki.archlinux.org/index.php/AMD_Catalyst#Configuring_the_driver

Vi0L0 commented on 2015-12-25 11:46

both gnome and gdm works fine here.
What do you mean by `accessing catalyst`? Does aticonfig work fine, can it detect your gpu ie when running `aticonfig --initial`? Whats your gfx? Was fglrx module build correctly?

Malekeith commented on 2015-12-25 11:31

It seems like GDM failed to start after I installed the latest updated drivers.

"linux gdm-launch-environment][494]: pam_systemd(gdm-launch-environment:session): Failed to create session: Resource deadlock avoided"

logging in and using startx helped override gdm. Do you know a fix ? or any method around, since even gnome seems to be acting all wonky

edit : catalyst not functioning, was because of qt4.

other errors, including gdm not working and most of the default desktop environment functions not responding

Vi0L0 commented on 2015-12-23 18:02

thanks JSpaces, updated to 15.201.2401:
- it's like 15.9 but better[1]
- by default it supports up to 4.2 and xserver 1.17
- with community patches up to 4.4 kernel, should also work with grsec kernel

[1]Looks like this driver is the first catalyst one with which my plasma 5.x glitches[2] are gone! :D Had to make some additional testing but definitelly none of the drivers get that far.

[2]http://ati.cchtml.com/show_bug.cgi?id=1182

EDIT: ah, no, looks like it was a coincidence and it was fixed in plasma 5.5.2! :D even better!

JSpaces commented on 2015-12-15 02:20

New driver was released on November 30.
version 15.201.2401