Package Details: campdown 1.46-1

Git Clone URL: https://aur.archlinux.org/campdown.git (read-only, click to copy)
Package Base: campdown
Description: Bandcamp track and album downloader
Upstream URL: https://github.com/catlinman/campdown/
Licenses: MIT
Replaces: python-campdown
Submitter: Jokler
Maintainer: Jokler
Last Packager: Jokler
Votes: 1
Popularity: 0.65
First Submitted: 2019-11-17 01:17
Last Updated: 2019-11-17 21:41

Latest Comments

Jokler commented on 2019-11-17 21:47

Thank you for your advice. The package should be updated accordingly now.

The reason I decided to add python-campdown to the conflicts() array was because wireshark-qt seemed to be doing the same. I probably misunderstood the intention of its maintainer though.

yochananmarqos commented on 2019-11-17 19:19

Please see Python package guidelines:

The source() array should be:

source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")

Add a build() array and the proper install flags in the package() array.

A package provides and conflicts with itself, no need for those at all. Since this is going to replace python-campdown, there's no need for it to be in conflicts().