Package Details: caffe2-cuda 0.8.2_1.8.1-1

Git Clone URL: https://aur.archlinux.org/caffe2.git (read-only, click to copy)
Package Base: caffe2
Description: A new lightweight, modular, and scalable deep learning framework (with cuda support)
Upstream URL: https://caffe2.ai/
Keywords: ai artificial cuda intelligence nvidia
Licenses: BSD
Conflicts: caffe2, python-pytorch
Provides: caffe2
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 0
Popularity: 0.000000
First Submitted: 2017-04-29 16:21
Last Updated: 2021-03-28 20:32

Dependencies (42)

Required by (2)

Sources (43)

Pinned Comments

dbermond commented on 2018-08-22 18:15

Important notice:

This package now provides the non-cuda version (as known as the 'cpu only' build).

If you want caffe2 with cuda support, use package caffe2-cuda. This new package naming schema will better reflect the package contents. This conforms to tensorflow package naming from the official repositories.

Latest Comments

1 2 3 4 Next › Last »

dbermond commented on 2021-05-26 17:37

@roachsinai The caffe2 package is for cpu-only (non-cuda) computations. So, what you're calling caffe2-cpu is actually caffe2. There is a pinned comment at the top of this page explaining this.

roachsinai commented on 2021-05-26 17:26

@dbermond thanks for your reply.

So there is caffe2 and caffe2-cude but no caffe2-cpu?

dbermond commented on 2021-05-26 16:19

@roachsinai This is a split package that builds both caffe2 (non-cuda, cpu-only) and caffe2-cuda. That's why you see two cmake calls on the build() function.

roachsinai commented on 2021-05-26 05:44

Hi, there. As already has caffe2-cude version, why in the PKGBUILD of caffe2 still include thing like cmake -B build-cuda -S pytorch?

dbermond commented on 2021-03-06 17:09

@petronny This is now fixed.

petronny commented on 2020-08-01 13:56

[ 96%] Building CXX object binaries/CMakeFiles/make_cifar_db.dir/make_cifar_db.cc.o
/usr/bin/ld: warning: libQt5Test.so.5, needed by /usr/lib/libopencv_highgui.so.4.4, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libQt5OpenGL.so.5, needed by /usr/lib/libopencv_highgui.so.4.4, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libQt5Widgets.so.5, needed by /usr/lib/libopencv_highgui.so.4.4, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libQt5Gui.so.5, needed by /usr/lib/libopencv_highgui.so.4.4, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libQt5Core.so.5, needed by /usr/lib/libopencv_highgui.so.4.4, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/lib/libopencv_highgui.so.4.4: undefined reference to `QWidget::showNormal()@Qt_5'
/usr/bin/ld: /usr/lib/libopencv_highgui.so.4.4: undefined reference to `QTimer::start(int)@Qt_5'
/usr/bin/ld: /usr/lib/libopencv_highgui.so.4.4: undefined reference to `QMutex::lock()@Qt_5'
/usr/bin/ld: /usr/lib/libopencv_highgui.so.4.4: undefined reference to `QAbstractSlider::setPageStep(int)@Qt_5'

Please add missing dependencies.

dbermond commented on 2019-06-29 18:41

@sleeping No need to delete caffe2 for now because python-pytorch and caffe2 are different packages. caffe2 can be used by people that want only it, without pytorch.

And pytorch does not provide the caffe2 binary executables.

sleeping commented on 2019-06-24 09:22

caffe was merged with PyTorch

this package should probably cease to exist?

dbermond commented on 2018-10-25 03:40

@petronny Yes, libibverbs was merged into rdma-core. Package updated.

petronny commented on 2018-10-22 05:46

libibverbs no longer exists in AUR now ... Should we use rdma-core?