Package Details: caffe-ssd ssdv1.0.r0.g4817bf8b-3

Git Clone URL: https://aur.archlinux.org/caffe-ssd.git (read-only, click to copy)
Package Base: caffe-ssd
Description: weiliu89's caffe
Upstream URL: http://caffe.berkeleyvision.org/
Licenses: BSD
Conflicts: caffe, caffe-cpu, caffe-cpu-git, caffe-dr-git, caffe-git, caffe-mnc-dr-git, caffe-ssd-cpu, caffe2, caffe2-cpu, caffe2-cpu-git, caffe2-git
Provides: caffe
Submitter: jerry73204
Maintainer: jerry73204
Last Packager: jerry73204
Votes: 0
Popularity: 0.000000
First Submitted: 2018-12-13 16:25
Last Updated: 2018-12-13 16:27

Latest Comments

arch202928 commented on 2020-02-26 02:45

Thank you! @jerry73204 I didn't know there are AUR helpers before.

Unfortunately now the problem is failing to install gcc6,

checking for readdir... yes
configure: updating cache .././config.cache
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing depfiles commands
make[1]: Leaving directory '/home/myname/.cache/yay/gcc6/src/gcc-build'
make: *** [Makefile:917: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

jerry73204 commented on 2020-02-25 09:12

Hi arch202928,

Looks like you makepkg the package and then install by pacman. Some dependencies, such as openblas-lapack, are only available on AUR. Pacman does not track the packages on AUR, so it complains about missing deps. You have to install AUR helpers to do the job for you.

Pick your favorite helper here. Personally, I use yay. https://wiki.archlinux.org/index.php/AUR_helpers

arch202928 commented on 2020-02-25 03:30

Failed to install:

error: target not found: openblas-lapack
error: target not found: python-leveldb
error: target not found: python-scikit-image
error: target not found: python-pydotplus
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> cuda
  -> cudnn
  -> cython
  -> python-scipy
  -> python-matplotlib
  -> python-networkx
  -> python-nose
  -> python-gflags
  -> openblas-lapack
  -> python-leveldb
  -> python-scikit-image
  -> python-pydotplus
==> Checking buildtime dependencies...
==> Installing missing dependencies...
error: target not found: gcc6
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> gcc6
==> ERROR: Could not resolve all dependencies.