Package Details: buttermanager 2.4-1

Git Clone URL: https://aur.archlinux.org/buttermanager.git (read-only, click to copy)
Package Base: buttermanager
Description: Graphical tool to create BTRFS snapshots, balance filesystems and upgrade the system safetly
Upstream URL: https://github.com/egara/buttermanager
Licenses: GPL
Submitter: egarcia
Maintainer: egarcia
Last Packager: egarcia
Votes: 5
Popularity: 0.40
First Submitted: 2018-12-24 17:23
Last Updated: 2021-03-31 06:54

Pinned Comments

egarcia commented on 2021-02-20 08:47

IMPORTANT!: Manual intervention for upgrading ButterManager from 2.3-1 to 2.3-2.

Sorry, I made a mistake packaging the new version 2.3-1 of ButterManager in AUR. The way the application is installed in this version is different because no virtual environment is required anymore. Because of this, I changed PKGBUILD but I introduced a mistake on it. Now, it is fixed in version 2.3-2, but manual intervention is required for upgrading. First, try to upgrade normally ButterManager using your AUR package manager. You can see some errors:

error: failed to commit transaction (conflicting files)
python-pyqt5: /usr/bin/pylupdate5 exists in filesystem
python-pyqt5: /usr/bin/pyrcc5 exists in filesystem
python-pyqt5: /usr/bin/pyuic5 exists in filesystem
Errors occurred, no packages were upgraded.
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> python-pyaml
  -> python-pyqt5
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

This error is due to in the previous package version (2.3-1) this library was installed by Python itself in the system instead of using the version which is in Arch repository (python-pyqt5). Now, this dependency is included from Arch repository (as well as python-pyaml) but it cannot be installed because the files are already in the filesystem (due to the previous installation). Please, move those files to another location (for example home) and try to upgrade again:

sudo mv /usr/bin/pylupdate5 ~/
sudo mv /usr/bin/pyrcc5 ~/
sudo mv /usr/bin/pyuic5 ~/

Now, another error can rise:

error: failed to commit transaction (conflicting files)
buttermanager: /usr/bin/buttermanager exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Failed to install built package(s).

You have to remove this file:

sudo rm /usr/bin/buttermanager

Try again, and now the upgrading should work. After installation, run ButterManager and see if everything works OK. Check the rest of applications you have that depends on the moved packages (python-pyqt5). If they all work, you could remove all the files previously moved (pylupdate5, pyrcc5, pyuic5)

Again, sorry for the inconveniences. This error shouldn't appear anymore. Thanks to Solomon Choina and Grey Christoforo for the feedback. Thanks to them I have realized that the PKGBUILD file was wrong and I could fix it.

Latest Comments

ainola commented on 2021-02-25 19:54

No problem, egarcia. You're always welcome to reach out for any clarification in the mailing lists/irc. Thanks for the ack!

egarcia commented on 2021-02-25 08:51

Ok ainola, sorry for introducing this error in the PKGBUILD. Now it is fixed and I'll be extremely careful to follow the packaging guidelines. Thanks!

ainola commented on 2021-02-25 03:01

egarcia: As mentioned earlier, using sudo in these is a grave error. Thank you for correcting it and please refrain from doing it again.

You are highly advised to review the packaging guidelines [1][2] to better inform your packages. Badly-behaved packages will be taken down, so keep 'em clean!

[1] https://wiki.archlinux.org/index.php/Arch_package_guidelines

[2] https://wiki.archlinux.org/index.php/Creating_packages

egarcia commented on 2021-02-20 16:40

SolarAquarion you are right, I'll point the PKGBUILD to a tag instead of the master branch on the next release.

Thanks for the feedback!

SolarAquarion commented on 2021-02-20 14:15

Also change to a tagged release instead of the "Master branch" #tag=2.3, or just do https://github.com/egara/buttermanager/archive/"$pkgver".tar.gz

dr460nf1r3 commented on 2021-02-20 10:23

After building the new PKGBUILD in chroot Im getting the following while starting up: Traceback (most recent call last): File "/usr/lib/python3.9/site-packages/buttermanager/buttermanager/buttermanager.py", line 172, in load_main_window ButtermanagerMainWindow(self) File "/usr/lib/python3.9/site-packages/buttermanager/buttermanager/buttermanager.py", line 209, in __init__ self.init_ui() File "/usr/lib/python3.9/site-packages/buttermanager/buttermanager/buttermanager.py", line 300, in init_ui self.__current_filesystem = filesystem.Filesystem(self.__current_filesystem_uuid) File "/usr/lib/python3.9/site-packages/buttermanager/buttermanager/filesystem/filesystem.py", line 61, in __init__ filesystem_info = self.__get_filesystem_info(self.mounted_points[0]) IndexError: list index out of range fish: Job 1, 'buttermanager' terminated by signal SIGABRT (Abort)

egarcia commented on 2021-02-20 08:47

IMPORTANT!: Manual intervention for upgrading ButterManager from 2.3-1 to 2.3-2.

Sorry, I made a mistake packaging the new version 2.3-1 of ButterManager in AUR. The way the application is installed in this version is different because no virtual environment is required anymore. Because of this, I changed PKGBUILD but I introduced a mistake on it. Now, it is fixed in version 2.3-2, but manual intervention is required for upgrading. First, try to upgrade normally ButterManager using your AUR package manager. You can see some errors:

error: failed to commit transaction (conflicting files)
python-pyqt5: /usr/bin/pylupdate5 exists in filesystem
python-pyqt5: /usr/bin/pyrcc5 exists in filesystem
python-pyqt5: /usr/bin/pyuic5 exists in filesystem
Errors occurred, no packages were upgraded.
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> python-pyaml
  -> python-pyqt5
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

This error is due to in the previous package version (2.3-1) this library was installed by Python itself in the system instead of using the version which is in Arch repository (python-pyqt5). Now, this dependency is included from Arch repository (as well as python-pyaml) but it cannot be installed because the files are already in the filesystem (due to the previous installation). Please, move those files to another location (for example home) and try to upgrade again:

sudo mv /usr/bin/pylupdate5 ~/
sudo mv /usr/bin/pyrcc5 ~/
sudo mv /usr/bin/pyuic5 ~/

Now, another error can rise:

error: failed to commit transaction (conflicting files)
buttermanager: /usr/bin/buttermanager exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Failed to install built package(s).

You have to remove this file:

sudo rm /usr/bin/buttermanager

Try again, and now the upgrading should work. After installation, run ButterManager and see if everything works OK. Check the rest of applications you have that depends on the moved packages (python-pyqt5). If they all work, you could remove all the files previously moved (pylupdate5, pyrcc5, pyuic5)

Again, sorry for the inconveniences. This error shouldn't appear anymore. Thanks to Solomon Choina and Grey Christoforo for the feedback. Thanks to them I have realized that the PKGBUILD file was wrong and I could fix it.

SolarAquarion commented on 2021-02-19 21:27

What's with the sudo commands? Using sudo in a PKGBUILD is a no no

you should be installing the files in a $pkgdir, not via root