Package Details: buildstream-git 1.93.1+22+g0591b0c8b-1

Git Clone URL: https://aur.archlinux.org/buildstream-git.git (read-only, click to copy)
Package Base: buildstream-git
Description: Framework for modelling build pipelines in a declarative YAML format
Upstream URL: https://buildstream.build
Licenses: LGPL
Conflicts: buildstream
Provides: buildstream
Submitter: rafaelff
Maintainer: rafaelff
Last Packager: rafaelff
Votes: 1
Popularity: 0.000000
First Submitted: 2017-08-22 01:23
Last Updated: 2020-02-06 22:37

Latest Comments

jjardon commented on 2019-12-22 17:12

@rafaelff builbox-run-bubblewrap is the best choice. But from bst Devs: "buildbox-run is currently only used as an experimental sandboxing backend. the plan is to use it as primary backend in the future. however, right now it's not important for the average user"

rafaelff commented on 2019-12-18 06:28

@jjardon updated. I noticed a 'buildbox-run' being called in the source code (e.g. in .gitlab-ci.yml), but I found 'buildbox-run-bubblewrap', 'buildbox-run-userchroot' and 'buildbox-run-hosttools'. I can't tell whether this package should depend on one of these and which should it be. Do you know?

jjardon commented on 2019-11-19 20:57

@rafaelff buildstream-git now depends on https://gitlab.com/BuildGrid/buildbox/buildbox-casd and not in python-arpy or bzr anymore

jjardon commented on 2019-09-20 12:02

Hi, seems tag is in commit d06fd33a, which is in master

rafaelff commented on 2019-09-20 11:08

@jjardon: I notice some commits in 1.91.0 tag that are not included in master branch. Normally, VCS packages use the master branch as the latest development commit, but it seems to me it is not the case of BuildStream. Can you tell what is the proper branch/tag approach on BuildStream development?

jjardon commented on 2019-09-18 13:59

@rafaelff there is not a "1.91.0" tag in case you prefer to use that

jjardon commented on 2019-09-04 10:03

@rafaelff AFAIK cython It's a makedepends

rafaelff commented on 2019-09-04 09:47

@jjardon Thanks for the heads up. How about cython - is it only a checkdepends or a makedepends?

jjardon commented on 2019-09-04 07:54

@rafaelff also, it doesn't depend anymore on ostree or python-gobject

jjardon commented on 2019-09-04 07:47

No need to depend on a specific version of python-ruamel-yaml0.15.51 anymore