Package Details: buildnotify-git 1.0.4.r5.g3a9bb0d-1

Git Clone URL: https://aur.archlinux.org/buildnotify-git.git (read-only)
Package Base: buildnotify-git
Description: A system tray based build status notification app for cctray.xml feeds
Upstream URL: https://github.com/anaynayak/buildnotify
Licenses: GPL3
Conflicts: buildnotify, buildnotify-hg
Provides: buildnotify
Replaces: buildnotify-hg
Submitter: tomwadley
Maintainer: tomwadley
Last Packager: tomwadley
Votes: 2
Popularity: 0.000005
First Submitted: 2018-07-04 19:45
Last Updated: 2018-07-04 19:45

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

tomwadley commented on 2018-07-11 14:33

buildnotify-hg has been deleted. All comments have been brought over to this package, buildnotify-git. All comments below were for the old buildnotify-hg package.

tomwadley commented on 2018-07-04 19:47

Since the upstream moved to git, this package is no longer being maintained. Switch to "buildnotify" or "buildnotify-git" instead.

tomwadley commented on 2018-06-29 23:21

@ZimbiX would you like to take this package over? It looks like you've done the work already. Maybe you should create a new package called "buildnotify-git" (or maybe you could package the stable release which now exists and just call it "buildnotify"). If you do that, I'll mark this out of date and pin a comment linking to your new one. If you don't want to though, just let me know and I'll do it.

EDIT: I've gone and done this my self

ZimbiX commented on 2018-06-27 02:59

I had to make several changes to get it installed:

# Maintainer: Tom Wadley <tom@tomwadley.net>

pkgname=buildnotify-hg
pkgver=99999
pkgrel=1
pkgdesc="Cruise Control build monitor for Windows/Linux/Mac"
arch=('any')
url="https://github.com/anaynayak/buildnotify"
license=('GPL3')
depends=('python2' 'python2-pyqt5' 'python2-pytz' 'python2-dateutil')
makedepends=('mercurial' 'python2-setuptools')
source=("git+$url"
        "buildnotify.desktop")
md5sums=('SKIP'
         '2f25214b688c6eb571ad2bb52c13beec')

_installmodule() {
  pushd "${srcdir}/buildnotify"
  /usr/bin/python2 setup.py install --root="${pkgdir}/" --optimize=1
  popd
}

pkgver() {
  _installmodule > /dev/null 2>&1

  version=$(PYTHONPATH="${srcdir}/buildnotify/" /usr/bin/python2 <<EOF
import pkg_resources
print pkg_resources.require('buildnotify')[0].version
EOF
  )

  cd "${srcdir}/buildnotify"
  echo $(git describe --always | sed 's/-/./g')
}

package() {
  _installmodule

  cd "${srcdir}"

  install -D -m 644 buildnotify.desktop "${pkgdir}/usr/share/applications/buildnotify.desktop"

  cd buildnotify

  install -D -m 644 icons/buildnotify.svg "${pkgdir}/usr/share/pixmaps/buildnotify.svg"
}

# vim:set ts=2 sw=2 et:

tomwadley commented on 2017-07-16 03:18

Thanks @drew33. I'll admit I didn't actually have the package installed so hadn't caught the new dependency.

drew33 commented on 2017-07-15 21:26

Thanks Tom for the package - note that the dependency 'python2-keyring' is missing, however. Tried to push an update, but just remembered that only the maintainer can only do this - happy to take ownership if you are