Package Details: brother-mfc-j6510dw 3.0.0-5

Git Clone URL: https://aur.archlinux.org/brother-mfc-j6510dw.git (read-only, click to copy)
Package Base: brother-mfc-j6510dw
Description: LPR and CUPS driver for the Brother MFC-J6510DW
Upstream URL: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
Keywords: brother cups driver printer
Licenses: unknown
Submitter: lswest
Maintainer: lswest
Last Packager: lswest
Votes: 4
Popularity: 0.007068
First Submitted: 2011-10-18 16:06
Last Updated: 2021-01-18 15:08

Pinned Comments

lswest commented on 2021-01-13 16:43

I just set this up on a new computer, and lpadmin kept crashing when trying to add a printer using this driver.

Edit on 18th of Jan: Thanks to mossblaser, I've implemented a fix in the PKGBUILD (3.0.0-5) which should allow this driver to continue to work with Arch's version of CUPS.

Alternatively, you can use the printer with the IPP Everywhere driver, and the URI ipp://<IP>:631/ipp.

Replace <IP> with the IP of your printer. I'm leaving this comment here for posterity, and for anyone who runs into a similar issue.

Latest Comments

« First ‹ Previous 1 2 3

rggjan commented on 2013-08-24 10:44

3.0.0-1 is out:
http://welcome.solutions.brother.com/bsc/public/eu/eu_ot/en/dlf/download_index.html?reg=eu&c=eu_ot&lang=en&prod=mfcj6510dw_all&dlid=&flang=English&os=128&type2=-1