Package Details: brother-hl2140 2.0.2_1-4

Git Clone URL: https://aur.archlinux.org/brother-hl2140.git (read-only, click to copy)
Package Base: brother-hl2140
Description: LPR and CUPS driver for the Brother HL2140
Upstream URL: http://solutions.brother.com/linux/en_us/
Keywords: 2140 brother driver hl2140 printer
Licenses: custom:brother commercial license
Submitter: louipc
Maintainer: severach
Last Packager: FacuTuesca
Votes: 15
Popularity: 0.000007
First Submitted: 2009-06-05 12:58
Last Updated: 2016-05-13 11:53

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

louipc commented on 2011-04-15 23:30

The patch is mainly to disable the code that does screwy stuff so we can just extract the ppd file and lpdwrapper.
I got kind of fancy with it though. See this wiki page:
https://wiki.archlinux.org/index.php/Creating_packages_for_Brother_drivers

Anonymous comment on 2011-04-15 22:48

@xav and others:
Brother drivers are designed for LPD. When you use CUPS, files in /usr/share/Brother/inf get updated by /usr/share/Brother/cupswrapper/brcupsconfig3 on every print to pass the current options. In order to make the printer configurable you should put its alphanumeric model name into file: /usr/share/Brother/inf/brPrintList. E. g. I have Brother HL-2140 (there is file /usr/share/Brother/inf/brHL2140rc) and I must have "HL2140" in /usr/share/Brother/inf/brPrintList (I have no idea why my old comments clarifying this here have disappeared). Thus the current .install script is wrong. Instead of
cat /usr/share/Brother/inf/brHL2140rc >> /usr/share/Brother/inf/brPrintList
it should have something like
grep --quiet "^$MODEL\$" '/usr/share/Brother/inf/brPrintList' || echo "$MODEL" >> '/usr/share/Brother/inf/brPrintList'
in post_install() and also something like
echo `cat '/usr/share/Brother/inf/brPrintList'` | grep --invert-match "^$MODEL\$" > '/usr/share/Brother/inf/brPrintList'
in pre_remove().

tri1976 commented on 2011-04-15 21:15

I'd like to create a similar package for my Brother printer HL-2240. Can you tell me what does patch file patch? Thanks.

Anonymous comment on 2011-04-04 00:49

I am not sure what is going wrong here, but I can offer a few suggestions:

1. Manually adjust the margins to make them right. How to do this varies depending on how you are printing.

2. Try removing hl2140 from /usr/share/Brother/inf/brPrintList

3. Re-install the old package that was working correctly.

4. See what happens when you print a test page (not a page printed as a test from external software).

kosmiciatakuja commented on 2011-04-03 10:41

I'm experiencing the problems with vertical margins as described below. I edited the brPrintList and brHL2140rc file. I reinstalled every package even remotely related to cups, including completely cleaning the configuration files during reinstall. I found and changed every possible option in cups and all programs I use to A4 paper (yes, I'm using A4). No luck - still no top margin, top of the page content is cut off and huge bottom margin.

Maybe there's something wrong in the PPD file? Can anybody offer any suggestions, tips?

Thanks!

Anonymous comment on 2011-03-30 21:52

Updated to use bsdtar directly rather than through rpmextract.

Anonymous comment on 2011-03-30 21:29

xav: /usr/share/Brother/inf/brPrintList sets the default PaperType to Letter (US). If you use A4 paper, then you should change this. You may also need to change options in whatever program you are printing from/with in order to tell it you are using A4 paper. I am not sure what version of the package you were using before. It may not have been using any default configuration. Let me know if this does not work.

xav commented on 2011-03-30 12:03

I just made an update of this package from a previous version that worked perfectly.

A4 top margins are now completely fucked up, I dont have the beginning of the page, and bottom margins seems oversized.

How guys do you fix this ?

louipc commented on 2011-03-29 04:53

Seems like rpmextract is no longer needed. bsdtar from libarchive can extract the rpms.

Anonymous comment on 2011-02-23 12:17

Updated with fixes from louipc.