Package Details: brother-dcpj132w 3.0.0-5

Git Clone URL: https://aur.archlinux.org/brother-dcpj132w.git (read-only, click to copy)
Package Base: brother-dcpj132w
Description: Driver for the Brother DCP-j132w wifi multifuncional printer
Upstream URL: http://solutions.brother.com/linux/en_us/index.html
Licenses: custom:brother
Submitter: josesj
Maintainer: josesj
Last Packager: josesj
Votes: 0
Popularity: 0.000000
First Submitted: 2018-07-15 14:34
Last Updated: 2018-11-03 08:50

Latest Comments

fipm commented on 2018-11-02 21:48

I am getting the following error:

:: Processing package changes...
/tmp/alpm_lq6oZl/.INSTALL: line 6: syntax error near unexpected token `}'
/tmp/alpm_lq6oZl/.INSTALL: line 6: `}'
/usr/bin/bash: pre_upgrade: command not found

joserebelo commented on 2018-10-20 17:20

@josesj I think you forgot to update the rest of the PKGBUILD.

Anyway, I have this printer and would be willing to take over the package.

josesj commented on 2018-10-19 14:47

I updated the PKGBUILD with the suggested changes. Thanks! Unfortunately I can't check the changes on my system because I don't have this printer anymore, sorry.

If somebody wants to adopt the package, go ahead...

joserebelo commented on 2018-10-19 10:44

This patch fixes the package installation, and adds the printer to the models list (based on brother-hl1210w).

--- PKGBUILD.old    2018-10-19 11:37:35.000000000 +0100
+++ PKGBUILD    2018-10-19 11:40:18.000000000 +0100
@@ -1,14 +1,13 @@
 # Contributor: bilux <i.bilux@gmail.com>
 # Maintainer: josesj <josesj@gmail.com>

-pkgname=brother-dcpj152w
+pkgname=brother-dcpj132w
 pkgver=3.0.0
 pkgrel=1
 pkgdesc="Driver for the Brother DCP-j132w wifi multifuncional printer"
 url="http://solutions.brother.com/linux/en_us/index.html"
 license=('custom:brother')
 depends=('a2ps' 'cups')
-install="brother-dcpj132w.install"
 arch=('i686' 'x86_64')

 md5sums=('c300b0af971adc0da0c7fc475d49bc84'
@@ -26,14 +25,11 @@
    patch -Np0 < fix_lp.patch
 }

-post_install() {
-   /opt/brother/Printers/dcpj132w/cupswrapper/cupswrapperdcpj132w
-}
-
-package()
-{
-    install -d $pkgdir/usr/bin
-   install -d $pkgdir/var/spool/lpd
-    install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj132w "$pkgdir"/usr/bin/
-   cp -R $srcdir/opt $pkgdir/opt
+package() {
+    mkdir -p "$pkgdir/usr/share/cups/model/"
+    mkdir -p "$pkgdir/usr/lib/cups/filter/"
+
+    cp "$srcdir/opt/brother/Printers/dcpj132w/cupswrapper/brother_dcpj132w_printer_en.ppd" "$pkgdir/usr/share/cups/model/brother_dcpj132w_printer_en.ppd"
+    cp "$srcdir/opt/brother/Printers/dcpj132w/lpd/filterdcpj132w"  "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_dcpj132w"
+    cp -r "$srcdir/opt/" "$pkgdir/opt/"
 }

fbestie commented on 2018-10-17 21:52

When, I try to install, I receive this message Could not find PKGDEST for: brother-dcpj132w how can i fix this ?