Package Details: brlcad 7.32.2-0

Git Clone URL: https://aur.archlinux.org/brlcad.git (read-only, click to copy)
Package Base: brlcad
Description: An extensive 3D solid modeling system.
Upstream URL: https://brlcad.org
Keywords: CAD
Licenses: BSD, LGPL, custom:BDL
Submitter: louipc
Maintainer: ejno
Last Packager: ejno
Votes: 66
Popularity: 1.06
First Submitted: 2007-02-04 02:47
Last Updated: 2021-02-14 18:45

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

thebunnyrules commented on 2016-12-15 11:03

Has anyone else come across this issue? Or knows how to resolve it?

I'm trying to compile release 7.26.02. And I got this error:

Code to determine current date and time failed!

So, I went into /CMakeLists.txt (the main one) and entered the build date manually, replacing:

message(FATAL_ERROR "Code to determine current date and time failed!\n")
[this us the line that gives the fatal error if date and time protocol fail]
with:
set(CONFIG_DATE "161214") #<===== I also tried "20161214"
[I simply replaced the automatic datestamp with a manual one to get around the problem]

After making this substitution, it seems to be working well for 70% of the cmake process but then I hit this error where it says that it was unable to find Tcl, itcl or Tk libraries depite the fact they are installed and in directories where CMake was searching (see list below)

Here are the details:

ERROR MESSAGE:
Could not find at least one of Tcl, Itcl or Tk libraries in /usr/lib64,
/usr/lib64/itcl4.0.5, and /usr/lib64

Here are the contents of the Tcl,Itcl and Tk lib folders:

/usr/lib64/itcl4.0.5/

itclConfig.sh
itclHullCmds.tcl
itcl.tcl
itclWidget.tcl
libitcl4.0.5.so
libitclstub4.0.5.a
pkgIndex.tcl

/usr/lib64/tk8.6/

see this pastebin: http://pastebin.com/kW2Cdig5

/usr/lib64/tcl8.6/

see this: http://pastebin.com/xk1tVTUv

It seems to me, I have all the needed libraries and the correct versions. I have check permission and everyone of the directories has read permissions given to everyone.

Any ideas?

ejno commented on 2016-08-13 16:56

Updated to 7.26.0. Release notes are available at https://sourceforge.net/projects/brlcad/files/BRL-CAD%20Source/7.26.0/

ejno commented on 2016-06-02 00:27

@gjw: Thanks, should be fixed now.

gjw commented on 2016-05-27 16:58

It does not build any more.
It stops at 44 percentage.
It seems to me that some
functions in the boost libraries
have been removed and put
into g++ instead.

lenzj commented on 2015-12-13 14:11

@ejno: It compiles and works well now. Thanks again.

ejno commented on 2015-12-13 05:44

@lenzj: Thanks, should be fixed now.

lenzj commented on 2015-12-12 12:40

I'm getting the following error during compile:
/tmp/pacaurtmp-/brlcad/src/brlcad-7.24.2/src/other/boost/boost/xpressive/detail/static/transmogrify.hpp:42:46: error: no type named ‘string_type’ in ‘struct boost::xpressive::cpp_regex_traits<char>’
typedef typename Traits::string_type string_type;

ejno commented on 2015-03-12 12:59

@lenzj: Great, thanks for confirming!

lenzj commented on 2015-03-12 12:28

@finale: I've confirmed that it's compiling successfully for me now. Thank you!

ejno commented on 2015-03-12 06:32

@lenzj: Should be fixed now.