Package Details: brave-git 1.25.33.g0126e4e-1

Git Clone URL: (read-only, click to copy)
Package Base: brave-git
Description: A web browser that stops ads and trackers by default. Master branch.
Upstream URL:
Keywords: browser web
Licenses: BSD, Apache, custom:MPL2, custom:others
Conflicts: brave
Provides: brave, brave-browser
Submitter: vorbote
Maintainer: Ta180m
Last Packager: Ta180m
Votes: 25
Popularity: 0.25
First Submitted: 2016-04-06 13:15
Last Updated: 2021-10-28 22:14

Dependencies (24)

Required by (3)

Sources (13)

Latest Comments

1 2 3 Next › Last »

Mishka commented on 2021-10-28 04:44

    add-clang-nomerge-attribute-to-CheckError.patch ... FAILED
    chromium-glibc-2.33.patch ... FAILED
    use-oauth2-client-switches-as-default.patch ... FAILED
==> ERROR: One or more files did not pass the validity check!

troyBORG commented on 2020-03-09 01:37

Error: Command 'vpython src/third_party/depot_tools/ --no_resume --no_auth --bucket chromium-clang-format -s src/buildtools/linux64/clang-format.sha1' returned non-zero exit status 1 in /home/troyborg/.cache/yay/brave-git/src/brave-browser
npm ERR! errno 1
npm ERR! brave@1.7.51 init: `node ./scripts/sync.js --init`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the brave@1.7.51 init script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/troyborg/.npm/_logs/2020-03-09T00_55_03_676Z-debug.log
==> ERROR: A failure occurred in build().
Error making: brave-git

cg505 commented on 2019-07-31 23:06

This PKGBUILD does not work. You should use the approach used in the brave AUR package.

Stykers commented on 2019-05-21 09:02

@pzlds the old repo was archived, i will fix this now

pzlds commented on 2019-05-21 08:24


You just pushed something to prod without even trying to test it (Or at least it seems so, since the build errors out half a minute into the "preparing" process). Could you at least revert your change to restore the package into a buildable state?

timschumi commented on 2019-03-08 14:34

As an update on the update: I still can't get the scripts to use python2 in all cases, but I have made progress (i.e. modifying the shebangs works in most of the cases, but some scripts seem to be explicitly called with python, and I can't find where. Virtualenv seems to not work in that case either.)

I'm going to disown the package, in case anyone else wants to try fixing this up. I uploaded my modifications to the repository (, feel free to base whatever you are trying on this. Please note that since I didn't manage to make it fully build, the packaging steps aren't correct.

As a side note: You are now building Chromium with Brave's patches (in case anyone gets this to work). That means hours of build time (felt like 10h on my 2x2,7 GHz CPU) and lots of used disk space (about 70 GB (yes, Gigabytes) in my tests (~20 GB are downloaded), but maybe I missed something that can be omitted to further reduce that).

I don't even know if a -git package for Brave is viable anymore.

timschumi commented on 2018-10-21 09:59

@tuckerboniface The new location alone won't help much (is there even a reason to use it, as the old repository is still being updated?). Due to changes in Brave's build system for the next-gen version, the PKGBUILD is massively broken by now. I took a look at it and tried to fix a few things, but unfortunately, the Chromium scripts assume that python2 is installed as "python", which isn't the case on Arch. If anyone with enough nodeJS knowledge and enough time on their hands is able to come up with a solution to make nodeJS modify the shebang lines between cloning depot_tools and running them, I'll happily switch this to the next-gen version.

tuckerboniface commented on 2018-10-21 02:18

Please use the new location

oberon2007 commented on 2018-05-29 00:25

pkgver is broken. Since the repo doesn't provide proper rel tags you should just use

printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

current result is 'r9490.971344519'

urldog commented on 2017-12-23 09:37

I get: Error installing brave-git : invalid version string: 0.22.0.^3.0.18419.

Using yay, manjaro.