Package Details: brainworkshop 5.0.1-1

Git Clone URL: https://aur.archlinux.org/brainworkshop.git (read-only, click to copy)
Package Base: brainworkshop
Description: Brain Workshop is a free open-source version of the Dual N-Back mental exercise
Upstream URL: https://github.com/samcv/brainworkshop
Licenses: GPL
Submitter: xantares
Maintainer: xantares
Last Packager: xantares
Votes: 8
Popularity: 0.097132
First Submitted: 2015-10-13 20:02
Last Updated: 2020-05-27 07:55

Latest Comments

« First ‹ Previous 1 2 3

xantares commented on 2017-11-22 13:31

What's your pyglet version (python2) ?
Do you have the full traceback ?

josealb77 commented on 2017-11-22 12:50

"data" and "res" folders where placed in the folder "/usr/share/brainworkshop". "brainworkshop.pyw" was there too.

I updated the application to -5 version but I still got the same error. Uninstalled brainworkshop 4.8.4-5 and reinstalled it but I had the same error. Moved both folders to /usr/lib/python2.7/site-packages/pyglet/extlibs/future/py2/ that is where python2 is looking for them and the problem was solved. Nevertheless... i don't know if it is a clean way to solve that problem. Shouldn't the python2 executable looked for them before in the application folder?

xantares commented on 2017-11-22 12:09

I had to fix errors due to the pyglet 1.3.0 update, but did not encounter yours @josealb77.

josealb77 commented on 2017-11-21 18:56

$ brainworkshop
Error: the resource folder
/usr/lib/python2.7/site-packages/pyglet/extlibs/future/py2/res does not exist or is not readable. Exiting

xantares commented on 2017-02-11 16:43

brainworkshop keeps its files in ~/.brainworkshop

fausterjames commented on 2017-02-11 12:48

The time spent isn't updating unless I remove the package and reinstall it, then it will update once. I tried to uninstall completely with pacman -Rn but the history remains for some reason.

xantares commented on 2016-02-20 08:03

@yabbe, it's a pyglet package bug:
https://bugs.archlinux.org/task/48262?project=5&cat[0]=33&string=python-pyglet

yabbe commented on 2016-02-20 06:45

Error:
ImportError: Library "GLU" not found.

Fix:
pacman -S glu