Package Details: brackets 1.14-2

Git Clone URL: https://aur.archlinux.org/brackets.git (read-only)
Package Base: brackets
Description: An open source code editor for the web, written in JavaScript, HTML and CSS.
Upstream URL: http://brackets.io
Licenses: MIT
Conflicts: brackets-bin, brackets-git
Submitter: 4javier
Maintainer: petronny
Last Packager: petronny
Votes: 101
Popularity: 0.931199
First Submitted: 2013-12-05 11:44
Last Updated: 2019-05-04 04:05

Required by (0)

Sources (9)

Pinned Comments

petronny commented on 2017-11-24 05:10

Prebuilt binaries of this package can be found in arch4edu.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

axedre commented on 2017-04-24 19:21

Hi, any updates on this? I have updated to brackets 1.9 on my windows office pc and would love getting this update for my home pc running arch, since it includes some pretty useful features. Thanks for your hard work.

petronny commented on 2017-03-27 16:28

Here is a compiled package for 1.8
https://mirrors.tuna.tsinghua.edu.cn/arch4edu/x86_64/brackets-1.8-1-x86_64.pkg.tar.xz
if you need to downgrade it.

I'm trying to compile the right CEF myself.

petronny commented on 2017-03-26 15:38

@raven920 Thanks for report. I'm working on it.

raven920 commented on 2017-03-26 13:53

This package (ver 1.9-1) is lacking some JS dependencies which prevents Brackets from running properly.

I had to manually download and copy CodeMirror, less and semver into /opt/brackets/www/thirdparty to make it work.

EDIT: there are more dependencies missing, actually had to download the deb and grab all the missing deps from it.

iskenderoguz commented on 2017-03-25 17:43

I updated brackets from 1.8 to 1.9, not it does not work. When I open it, there is only white blank screen

petronny commented on 2017-03-25 09:38

Hi, I picked up this package and updated it to 1.9.
It is packaged successfully but I don't know how it works.
I don't use this either, so please comment if anyone want to maintain it.

@alfredo.ardito You can use libudev0-shim instead of libudev0

4javier commented on 2017-03-23 15:40

I don't use this tool, the upgrade to 1.9 doesn't work, and after two years it seems that Linux version still run over an old version of CEF and nobody cares. I disown it.

denciu commented on 2017-03-23 13:51

Please update to 1.9

alfredo.ardito commented on 2017-03-18 14:43

Hello I failed to install brackets.
The following error occurred:
---------------------------------------------------------------
In file included from src/keymap/keymap.c:41:0:
src/keymap/keys-from-name.h:158:1: error: conflicting types for ‘lookup_key’
lookup_key (register const char *str, register size_t len)
^~~~~~~~~~
src/keymap/keymap.c:39:19: note: previous declaration of ‘lookup_key’ was here
const struct key* lookup_key (const char *str, unsigned int len);
^~~~~~~~~~
make[2]: *** [Makefile:2051: src/keymap/keymap-keymap.o] Error 1
make[1]: *** [Makefile:3190: all-recursive] Error 1
make: *** [Makefile:1333: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build libudev0.
==> Restart building libudev0 ? [y/N]
==> ---------------------------------
==>
==> WARNING: Dependencies have been installed before the failure
checking dependencies...

Package (2) Old Version Net Change

gyp-git 2103.aae1e3ef-1 -1.90 MiB
libgcrypt15 1.5.6-1 -0.52 MiB

Total Removed Size: 2.42 MiB

:: Do you want to remove these packages? [Y/n]
---------------------------------------------------------------

petronny commented on 2016-11-28 09:50

gtk2 should be in makedepends
nss should be in depends