Package Details: brackets 1.14.1-2

Git Clone URL: https://aur.archlinux.org/brackets.git (read-only, click to copy)
Package Base: brackets
Description: An open source code editor for the web, written in JavaScript, HTML and CSS.
Upstream URL: http://brackets.io
Licenses: MIT
Conflicts: brackets-bin, brackets-git
Submitter: 4javier
Maintainer: petronny
Last Packager: petronny
Votes: 105
Popularity: 0.65
First Submitted: 2013-12-05 11:44
Last Updated: 2020-02-05 04:44

Required by (0)

Sources (13)

Pinned Comments

petronny commented on 2017-11-24 05:10

Prebuilt binaries of this package can be found in arch4edu.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

bassam commented on 2020-09-29 04:38

@Musikolo So I installed node v12.18.3 (Latest LTS: Erbium). I still get the same error however:

Make sure your network and proxy settings are correct.

If you continue to have issues, please report this full log at https://github.com/Medium/phantomjs
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN notsup Unsupported engine for rewire@1.1.2: wanted: {"node":"<0.12.x"} (current: {"node":"12.18.3","npm":"6.14.7"})
npm WARN notsup Not compatible with your version of node/npm: rewire@1.1.2
npm WARN notsup Unsupported engine for watchpack-chokidar2@2.0.0: wanted: {"node":"<8.10.0"} (current: {"node":"12.18.3","npm":"6.14.7"})
npm WARN notsup Not compatible with your version of node/npm: watchpack-chokidar2@2.0.0
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/watchpack/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN Brackets@1.14.1-0 No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! phantomjs@1.9.18 install: `node install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the phantomjs@1.9.18 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/bassam/.npm/_logs/2020-09-29T04_31_00_665Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...

:/

Musikolo commented on 2020-09-29 03:39

@bassam, it looks to me you have Node.js v14 which is incompatible to build brackets. You should try installing Node.js v2:

pacman -Sy nodejs-lts-erbium

In theory, that should solve your issue.

I hope it helps.

bassam commented on 2020-09-29 03:07

Can't seem to build. Getting way too many npm errors to post but here's a sample. I made sure to disable pihole and my vpn service for the second try but that didn't help.

...
Make sure your network and proxy settings are correct.

If you continue to have issues, please report this full log at https://github.com/Medium/phantomjs
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN notsup Unsupported engine for rewire@1.1.2: wanted: {"node":"<0.12.x"} (current: {"node":"14.10.0","npm":"6.14.7"})
npm WARN notsup Not compatible with your version of node/npm: rewire@1.1.2
npm WARN notsup Unsupported engine for watchpack-chokidar2@2.0.0: wanted: {"node":"<8.10.0"} (current: {"node":"14.10.0","npm":"6.14.7"})
npm WARN notsup Not compatible with your version of node/npm: watchpack-chokidar2@2.0.0
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/watchpack/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN Brackets@1.14.1-0 No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! phantomjs@1.9.18 install: `node install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the phantomjs@1.9.18 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/bassam/.npm/_logs/2020-09-29T02_31_12_336Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...

MiraMaX166 commented on 2020-09-03 12:26

During installation, an error occurs and compilation is interrupted.

phantomjs@1.9.18 install/var/cache/private/pikaur/build/brackets/src/brackets/node_modules/phantomjs
node install.js

invalid config loglevel="notice"
Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2
Saving to /tmp/phantomjs/phantomjs-1.9.8-linux-x86_64.tar.bz2
Receiving...
[=============================-----------] 72% 0.0s
Error requesting archive.
Status: 404
Request options: {
"uri": "https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2",
"encoding": null,
"followRedirect": true,
"headers": {},
"strictSSL": true
}

Tell me what could be the problem. Thank.

macxcool commented on 2020-08-14 01:08

@petrony, can you unflag this? You should be able to just click 'unflag package' under Package Actions on the right. Thanks.

petronny commented on 2020-06-14 06:38

@TheGoliath version 1.14.2 is not for linux.

Brackets 1.14.2 is here! This release is targeted for Mac and Windows users only.

Musikolo commented on 2019-05-05 05:06

@petronny, I don't code in PHP, so I don't need it. Best approach could be to add it as an optional dependency (optdepends section) for PHP support. However, I cannot imagine anybody coding in PHP language without the php package installed.

petronny commented on 2019-05-05 04:48

@Musikolo Is the PHP support still working after force removing?

Musikolo commented on 2019-05-05 00:57

@petronny, I think composer and php packages should only be required for building brackets. So, they should be moved to the makedepends section. I forced removing those, and brackets works the same for me.

Thoughts?

slav commented on 2019-05-04 16:55

Brackets v.1.14-2 resolved issue. Thank you for quick response.