Package Details: brackets-bin 1.14-2

Git Clone URL: https://aur.archlinux.org/brackets-bin.git (read-only)
Package Base: brackets-bin
Description: A code editor for HTML, CSS and JavaScript.
Upstream URL: http://brackets.io
Licenses: MIT
Conflicts: brackets, brackets-git
Provides: brackets=1.14
Submitter: danyf90
Maintainer: MrHritik
Last Packager: MrHritik
Votes: 137
Popularity: 0.271516
First Submitted: 2013-12-03 16:03
Last Updated: 2019-05-06 08:53

Pinned Comments

MrHritik commented on 2018-12-10 19:40

Currently works with a temporary patch suggested by @Musikolo.
https://github.com/adobe/brackets/issues/14485

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 Next › Last »

4javier commented on 2013-12-03 14:20

You missed the "rm -r /opt/brackets" statement in post-remove inside brackets.install. Without that, /opt/bracket will stay in place due to the symlinks.

Please, ask for merge of "brackets" to "brackets-deb" on mailing list. You will keep votes and comments.
This is an example of merge request
https://mailman.archlinux.org/pipermail/aur-general/2013-March/022414.html

danyf90 commented on 2013-12-03 09:26

Hi 4javier,
thanks for your hints, i've updated the package

4javier commented on 2013-12-03 00:16

Hi dany.
This is a new pkgbuild that downloads the right .deb for the architecture from the official server by a little trick. It also uses a workaround that avoid the need of libudev.so.0 packages (It takes advantage of the official wrapper executable that modify the library path to search inside /opt/brackets also).
I removed "execstack" snippet, then prelink makedepends. Are you sure they're needed?
I renamed it to brackets-deb, so please ask for deletion for this one, and use the new name, because I'm trying to build directly from source, and that PKGBUILD should have name "brackets".

http://pastebin.com/mb8nY79W

I moved all the symlinkings to the install file, so this is the new one

http://pastebin.com/i3gDYxdZ

Bye. :)

danyf90 commented on 2013-11-24 19:01

when i try to execute grunt setup i have an error: there is no setup target

4javier commented on 2013-11-23 18:15

see this pkgbuild https://aur.archlinux.org/packages/br/brackets-git/PKGBUILD

danyf90 commented on 2013-11-23 17:34

i can't find any instruction about how to install it from that tar.gz file

danyf90 commented on 2013-11-23 17:21

i didn't know that there was a tgz file for it. the linked file is the 32 or 64 bit version? i can't find it on github.

4javier commented on 2013-11-23 13:51

Why don't you simply use their git tags as download sources? Furthermore, thus you can download the tar.gz and not the .deb.
https://github.com/adobe/brackets/archive/sprint-34.tar.gz

despairblue commented on 2013-11-17 21:29

Funny, `wget http://download.brackets.io/file.cfm?platform=LINUX64&build=33` actually does work, with the -O parameter one would even get a reasonable file name, but makepkg uses curl by default. With curl it doesn't work...too bad.

Changing curl to wget in makepkg.conf works, but that's obviously not a good solution :)

kicka commented on 2013-11-16 07:31

Brackets Sprint 34 is out