Package Details: brackets-bin 1.14.1-1

Git Clone URL: https://aur.archlinux.org/brackets-bin.git (read-only, click to copy)
Package Base: brackets-bin
Description: A code editor for HTML, CSS and JavaScript.
Upstream URL: http://brackets.io
Licenses: MIT
Conflicts: brackets, brackets-git
Provides: brackets=1.14.1
Submitter: danyf90
Maintainer: MrHritik
Last Packager: MrHritik
Votes: 138
Popularity: 0.40
First Submitted: 2013-12-03 16:03
Last Updated: 2020-11-02 17:52

Pinned Comments

MrHritik commented on 2018-12-10 19:40

Currently works with a temporary patch suggested by @Musikolo.
https://github.com/adobe/brackets/issues/14485#issuecomment-489289266

Latest Comments

1 2 3 4 5 6 ... Next › Last »

MrHritik commented on 2020-11-05 17:49

plasmapotato: I'm unable to reproduce your issue. Can you provide a more verbose output? Use a paste service (ix.io, 0x0.st etc). Also, can you share your uname -r ?

plasmapotato commented on 2020-11-05 17:16

Pls update checksums thx.

==> Validating source files with sha512sums...
    data.tar.xzaa ... FAILED
    data.tar.xzab ... FAILED
==> ERROR: One or more files did not pass the validity check!

MrHritik commented on 2020-11-02 17:59

GFDevelop: I was waiting for the upstream to issue a patch before bumping the version. I've not looked away from the package. For now, I've updated to the latest version with the libcef.so offered by the old 1.12. It might bring some breaking changes, please report if it does.

erikdubois: I'm not sure if that's the case. Can you try reinstalling the package ?
Here is what I see for the symlink:
lrwxrwxrwx 1 root root 22 Nov 2 23:12 /usr/bin/brackets -> /opt/brackets/brackets

GFdevelop commented on 2020-11-02 10:13

Just you don't update this package from a year, please leave the package or add a co-mantainer.

erikdubois commented on 2020-03-24 19:18

Just noticed you create a /usr/bin inside /usr/bin is that by accident or is it your intention.

So the brackets symlink is in /usr/bin/usr/bin/brackets

alfredo.ardito commented on 2019-05-06 14:19

Perfect, installed successfully, thx!

MrHritik commented on 2019-05-06 08:54

@alfredo.ardito, noextract should have taken care of that. Anyways, can you try again now ?

alfredo.ardito commented on 2019-05-06 06:36

Failed to install the package. Got this error:

==> Validating source files with sha512sums...
data.tar.xzaa ... Passed
data.tar.xzab ... Passed
data.tar.xzac ... Passed
==> Extracting sources...
-> Extracting data.tar.xzaa with bsdtar
opt/brackets/libcef.so: Lzma library error: No progress is possible
bsdtar: Error exit delayed from previous errors.
==> ERROR: Failed to extract data.tar.xzaa
Aborting...
==> ERROR: Makepkg was unable to build brackets-bin.
==> Restart building brackets-bin ? [y/N]
==> -------------------------------------
==> ==> ERROR: unable to update
No database errors have been found!

Musikolo commented on 2019-05-04 22:40

@MrHritik, I think you could solve the issue by replacing the CEF library with one used in AUR brackets package, as I found at https://github.com/adobe/brackets/issues/14485#issuecomment-489370499

Musikolo commented on 2019-05-02 18:55

Version 1.14 just released: