Package Details: bombono-dvd 1.2.4-5

Git Clone URL: https://aur.archlinux.org/bombono-dvd.git (read-only, click to copy)
Package Base: bombono-dvd
Description: DVD authoring program with nice and clean GUI
Upstream URL: http://www.bombono.org
Licenses: GPL
Conflicts: bombono-dvd-git
Submitter: sirocco
Maintainer: sbmomeni
Last Packager: sbmomeni
Votes: 76
Popularity: 0.000030
First Submitted: 2009-08-22 13:35
Last Updated: 2020-03-15 18:33

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

sirocco commented on 2012-11-16 02:38

As I read in Russian, it's upstream problem.
http://forum.bombono.org/viewtopic.php?f=2&t=12477

awagner commented on 2012-11-15 23:28

I got to compile somewhat further by using CPPFLAGS='-DBOOST_FILESYSTEM_VERSION=3' (instead of 2) in the PKGBUILD. However, due to this: http://forum.bombono.org/viewtopic.php?f=1&t=8422 it will not compile anyway.

Anonymous comment on 2012-07-18 05:00

Doesn't compile:

/usr/include/boost/filesystem/config.hpp:16:5: ошибка: #error Compiling Filesystem version 3 file with BOOST_FILESYSTEM_VERSION defined != 3
scons: *** [build/src/mgui/project/mconstructor-main.o] Error 1
scons: building terminated because of errors.

sirocco commented on 2012-05-09 14:10

An attempt to solve this problem.

Anonymous comment on 2012-05-07 21:01

Getting an error while trying to build it

-I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/lib/gtk-2.0/include -I/usr/include/gdk-pixbuf-2.0 -DBOOST_FILESYSTEM_VERSION=2 src/mgui/author/gb_devices.c
In file included from src/mgui/author/gb_devices.c:31:0:
/usr/include/glib-2.0/glib/gthread.h:28:2: error: #error "Only <glib.h> can be included directly."
In file included from src/mgui/author/gb_devices.c:32:0:
/usr/include/glib-2.0/glib/gmessages.h:28:2: error: #error "Only <glib.h> can be included directly."
In file included from src/mgui/author/gb_devices.c:33:0:
/usr/include/glib-2.0/glib/ghash.h:28:2: error: #error "Only <glib.h> can be included directly."
scons: *** [build/src/mgui/author/gb_devices.o] Error 1
scons: building terminated because of errors.

By the way, base-devel and all dependencies were installed. Also, I already have it installed, but it complains about boost missing, and I do have it, but on version 1.49, that's why I'm trying to re-install.

bombono-dvd: error while loading shared libraries: libboost_filesystem.so.1.48.0: cannot open shared object file: No such file or directory

sirocco commented on 2012-04-02 03:58

https://wiki.archlinux.org/index.php/AUR_User_Guidelines

Warning: Packages in the AUR assume "base-devel" is installed, and will not list members of this group as dependencies even if the package cannot be built without them. Please ensure this group is installed before complaining about failed builds.

Anonymous comment on 2012-04-02 03:23

Please add:
makedepends=('pkg-config')

psychedelicious commented on 2011-04-18 18:58

You also need to add scons as a dependency and not just a build dependency. DVD building fails without scons for me.

sirocco commented on 2011-04-18 02:24

Thank, done.

psychedelicious commented on 2011-04-15 19:36

Compilation fails with the new boost see this comment from the author for a fix to incorporate into the PKGBUILD:

http://bugs.gentoo.org/show_bug.cgi?id=362931#c2