Package Details: bluez-utils-compat 5.52-2

Git Clone URL: https://aur.archlinux.org/bluez-utils-compat.git (read-only, click to copy)
Package Base: bluez-utils-compat
Description: Development and debugging utilities for the bluetooth protocol stack. Includes deprecated tools.
Upstream URL: http://www.bluez.org/
Keywords: hciconfig hcidump hcitool
Licenses: GPL2
Conflicts: bluez-hcidump, bluez-hcitool, bluez-utils
Provides: bluez-hcidump, bluez-hcitool, bluez-utils
Replaces: bluez<=4.101, bluez-hcidump
Submitter: thurstylark
Maintainer: twa022
Last Packager: twa022
Votes: 27
Popularity: 1.75
First Submitted: 2017-03-02 17:34
Last Updated: 2019-11-22 01:59

Required by (31)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

thurstylark commented on 2017-05-09 13:07

@nicolasvila Can you try the build again with LANG=C?

Also, have you tried building in a clean chroot?

NicolasV commented on 2017-05-09 07:22

Latest version 5.45-1 crash during unit test:

[...]
PASS: unit/test-eir
PASS: unit/test-uuid
PASS: unit/test-textfile
PASS: unit/test-avctp
PASS: unit/test-avdtp
PASS: unit/test-gobex-transfer
PASS: unit/test-avrcp
./test-driver : ligne 107 : 9008 Erreur de segmentation (core dumped)"$@" > $log_file 2>&1
FAIL: unit/test-gatt
make --no-print-directory all-am
============================================================================
Testsuite summary for bluez 5.45
============================================================================
# TOTAL: 25
# PASS: 24
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0
============================================================================
See ./test-suite.log
============================================================================
make[3]: *** [Makefile:8493: test-suite.log] Error 1
make[2]: *** [Makefile:8601: check-TESTS] Error 2
make[1]: *** [Makefile:8985: check-am] Error 2
make: *** [Makefile:8987: check] Error 2
==> ERREUR : Une erreur s’est produite dans check().
Abandon...
==> ERREUR : Makepkg n'a pas pu construire bluez-utils-compat.
==> Relancer la compilation de bluez-utils-compat ? [o/N]
==> -----------------------------------------------------
==>
==> ERREUR : impossible de mettre à jour

thurstylark commented on 2017-04-25 15:44

Builds in a clean chroot just fine for me.

naraesk commented on 2017-04-20 16:44

valid pgp keys needs an update!

parkerlreed commented on 2017-03-22 18:44

All of this stuff getting deprecated (hcitool, hciconfig, gatttool) but what are the replacements? (short of installing this package)