Package Details: blockify 3.6.3-3

Git Clone URL: https://aur.archlinux.org/blockify.git (read-only)
Package Base: blockify
Description: Mutes Spotify advertisements.
Upstream URL: https://github.com/mikar/blockify
Licenses: MIT
Conflicts: blockify-git
Submitter: serialoverflow
Maintainer: serialoverflow
Last Packager: serialoverflow
Votes: 127
Popularity: 0.012679
First Submitted: 2013-12-19 22:18
Last Updated: 2016-11-29 23:36

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 Next › Last »

JP-Ellis commented on 2014-12-21 11:18

The source file tracks the master branch from Github resulting in the checksum failing for every new commit on the repository. Ideally, the source should be `https://github.com/mikar/blockify/archive/v1.2.tar.gz` (i.e. a fixed snapshot of the repository).

I have a created a git version of this package which trackes the latest changes on the github without checksum issues over at: `https://aur.archlinux.org/packages/blockify-git/`

ZaZam commented on 2014-12-13 17:01

IMO checksums are good for verifying that the files were downloaded correctly.

ZaZam commented on 2014-12-13 16:59

Incorrect sha256sum. For me it shows:
3a11e13125e9e840a0ded4fecfce4cefede5945f4d510aef5a7e46bbdb1c0494

I downloaded and checksummed multiple times.

silvik commented on 2014-12-13 12:51

Yeah, I'm probably one of the few that don't use pulseaudio. I can't give feedback about wine, because I don't use it.

I had no idea you are the author. Thank you for this great little program and maintaining an arch package.

serialoverflow commented on 2014-12-12 21:46

@silvik: thanks for the feedback. i wasn't sure anybody uses blockify without pulse. i'm also curious if people still use it with wine.
i'll make pulse optional again.

since i am both the author and maintainer and the files are hosted on github i personally don't see much use in checksums here. i'll include some with the next release anyway.

regards

silvik commented on 2014-12-12 15:31

The latest upgrade forced pulseaudio, but I have built the package without it and it works fine. I guess pulseaudio is not a hard dependency, it shoud be treated as optional dependency.

Also, checksums would be nice.

Thanks, useful package.

serialoverflow commented on 2014-05-03 17:34

thanks, done

bitwave commented on 2014-05-03 17:30

please add python2-setuptools to the depends. without it didn't work.

serialoverflow commented on 2014-05-02 15:42

Mareex' comment is outdated. Blockify uses the GTK framework now.
Cheers

serialoverflow commented on 2014-02-23 15:36

tk is mentioned in the PKGBUILD as an optional dependency as the GUI itself is optional, too. since tk+tcl is 11mb in size i don't really want to force that on anyone but i might add an extra hint in a post_install() function, thanks.