Package Details: blink 3.2.0-4

Git Clone URL: https://aur.archlinux.org/blink.git (read-only, click to copy)
Package Base: blink
Description: A state of the art, easy to use SIP client
Upstream URL: http://icanblink.com
Keywords: SIP VoIP
Licenses: GPL3, FreeBSD
Submitter: ogarcia
Maintainer: init (Mopman)
Last Packager: init
Votes: 11
Popularity: 0.41
First Submitted: 2016-06-18 13:13
Last Updated: 2019-09-25 21:56

Dependencies (15)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 Next › Last »

ogarcia commented on 2017-01-26 17:16

OK. I have the update. Take note that new package depends of updated python-sipsimple 3.1.0, and, at this moment, the python-sipsimple package is not updated in AUR.

In meantime, please pick this PKGBUILD http://sprunge.us/XHTY to update python-sipsimple BEFORE update blink.

Pastebin mirror http://pastebin.com/85sRLNLA of PKGBUILD.

NOTE: After qt5 5.8 update you must rebuild ALL AUR dependencies of blink and blink itself to avoid "mix incompatible Qt library" issue.

ogarcia commented on 2017-01-26 15:16

@theforeigner Hi, sorry for delay.

I do several test yesterday about udate blink to 3.0.1 but it fails with some errors. I'll work on it to update pkgbuild this afternoon. Stay tuned!

veganvelociraptr commented on 2017-01-26 13:07

Woohoo! I got Blink 3.0.1 running by installing it and all the dependencies manually.

python-sipsimple 3.1 installed by just altering the PKGBUILD. I'm no arch guru nor anyway near a pro, so I downloaded the Blink 3.0.1 zip manually from github. Then I proceeded to manually build and install the python files.

I also had to install python2-pyqt5 and python2-google-api-python-client to get it running. And there's the irritating bug when using any GTK based DE that prevents the Blink tray icon to be displaying, to which I used the "dbus-launch blink" workaround to get it back.

...but it works!

I hope all this is some help to you, ogarcia.

Once again, I apologize for not knowing my way around Arch Linux in general and PKGBUILD in particular and that these few pointers is all I can offer.

veganvelociraptr commented on 2017-01-26 12:40

@ogarcia: Is there any possibility you could upgrade this package to blink 3.0.1? I believe it fixes the recent errors that occur with newer python/qt4 version. On the other hand, it relies on a newer python-sipsimple 3.1.0, which could mean a great deal of work involved: http://devel.ag-projects.com/repositories/blink-qt/debian/changelog

wlp7s0 commented on 2017-01-24 08:36

@masolit
I have this problem too after last full system upgrade.
Downgrade those packages for blink to work:
pyqt4-common-4.12-1 -> pyqt4-common-4.11.4-5
python2-pyqt4-4.12-1 -> python2-pyqt4-4.11.4-5
python2-sip-4.19-1 -> python2-sip-4.18.1-2
python-sip-4.19-1 -> python-sip-4.18.1-2
sip-4.19-1 -> sip-4.18.1-2

Sip client is a critical application for me. I think we should wait till blink will update to use new python versions, till then I stuck with old python versions. And let's hope other applications won't update to use just the last python libraries.)

Anonymous comment on 2017-01-23 15:49

blink
:0: UserWarning: You do not have a working installation of the service_identity module: 'No module named service_identity'. Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied. Without the service_identity module and a recent enough pyOpenSSL to support it, Twisted can perform only rudimentary TLS client hostname verification. Many valid certificate/hostname mappings may be rejected.
libpng warning: iCCP: known incorrect sRGB profile
Traceback (most recent call last):
File "/usr/bin/blink", line 31, in <module>
blink = Blink()
File "/usr/lib/python2.7/site-packages/application/python/types.py", line 39, in __call__
return cls.__instantiate__(*args, **kw)
File "<string>", line 1, in __init__
File "/usr/lib/python2.7/site-packages/application/python/types.py", line 31, in instance_creator
cls.__instances__[key] = super(Singleton, cls).__call__(*args, **kw)
File "/usr/lib/python2.7/site-packages/blink/__init__.py", line 119, in __init__
self.main_window = MainWindow()
File "/usr/lib/python2.7/site-packages/blink/mainwindow.py", line 70, in __init__
self.setupUi()
File "/usr/lib/python2.7/site-packages/blink/mainwindow.py", line 214, in setupUi
super(MainWindow, self).setupUi(self)
File "<string>", line 316, in setupUi
File "/usr/lib/python2.7/site-packages/blink/sessions.py", line 2666, in __init__
self._hangup_shortcuts.append(QShortcut('Ctrl+Esc', self, member=self._SH_HangupShortcutActivated, context=Qt.ApplicationShortcut))
File "/usr/lib/python2.7/site-packages/blink/sessions.py", line 2648, in __init__
super(QShortcut, self).__init__(key, parent, member, ambiguousMember)
TypeError: QShortcut(QWidget): argument 4 has unexpected type 'NoneType'

ogarcia commented on 2017-01-16 12:20

@zatricky I make a simply revision update to "force" rebuild

zatricky commented on 2017-01-16 08:48

Heads-up. Rebuild required due to dependency libvncserver being updated from 0.9.10-4 to 0.9.11-1.

ogarcia commented on 2016-08-03 10:22

@promike

IMHO, not necessary that I adopt your packages. I think that you are working well and your packages are well maintained ;)

And about package names there are several docs about this:
https://wiki.archlinux.org/index.php/Arch_packaging_standards#Additional_guidelines
https://wiki.archlinux.org/index.php/VCS_package_guidelines

It's a pretty literature to go to bed... xD

promike commented on 2016-08-03 10:05

@ogarcia
Yes, I realized that our packages have some differences. I was unsure about your package name, I just simply copied mine from the AUR Archive, so I didn't have to think about this a lot, but I believe you.

[If you wish you can still adopt my Blink related packages, I wouldn't mind it at all]