Package Details: blender-git 2.81.r91063.ab519b91b2c-1

Git Clone URL: https://aur.archlinux.org/blender-git.git (read-only)
Package Base: blender-git
Description: A fully integrated 3D graphics creation suite (development)
Upstream URL: http://blender.org/
Licenses: GPL
Conflicts: blender
Provides: blender
Submitter: stativ
Maintainer: fbrennan (kureta)
Last Packager: kureta
Votes: 71
Popularity: 0.002154
First Submitted: 2013-12-05 10:11
Last Updated: 2019-10-08 19:36

Dependencies (28)

Required by (54)

Sources (6)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

kureta commented on 2019-10-02 21:25

@bartus are you on freenode irc or something? I would like to talk to you about your PKGBUILD and i don't want to clutter this comment section.

kureta commented on 2019-10-02 18:50

@bartus so are you saying if I remove optix after installing blender, Cycles OptiX device should continue to work without problems? Also isn't this package and yours are practically same? Should we merge them?

bartus commented on 2019-10-02 16:14

@kureta Shouldn't Optix go in to makedepends. Optix v7.0 is header only ( symbols are pulled from the drivers)

kureta commented on 2019-09-30 12:43

@bartus I've already modified PKGBUILD, compiled, installed, and tested optix rendering on an RTX graphics card. Everything works fine.

kureta commented on 2019-09-29 21:01

Hi! I have modified your PKGBUILD file a bit. Specifically:

  • removed cmake flags that are no longer applicable
    -DWITH_GAMEENGINE=ON \
    -DWITH_PLAYER=ON \
  • Added optional dependencies for OptiX and Open Image Denoise Support
    optdepends=('cuda: CUDA support in Cycles'
                'optix: OptiX support in Cycles'
                'oidn: Intel Open Image Denoise support in compositing')
  • Added logic for detection of these optional dependencies
    # check for optix
    _OPTIX_PKG=`pacman -Qq optix 2>/dev/null` || true
    if [ "$_OPTIX_PKG" != "" ]; then
        _EXTRAOPTS="$_EXTRAOPTS \
                    -DWITH_CYCLES_DEVICE_OPTIX=ON \
                    -DOPTIX_ROOT_DIR=/opt/optix"
    fi

    # check for open image denoise
    _OIDN_PKG=`pacman -Qq oidn 2>/dev/null` || true
    if [ "$_OIDN_PKG" != "" ]; then
        _EXTRAOPTS="$_EXTRAOPTS \
                    -DWITH_OPENIMAGEDENOISE=ON"
    fi

Maybe you can incorporate these changes into your PKGBUILD too.

bartus commented on 2019-06-17 14:59

@fbrennan: Consider updating pkgver scheme to preserve consistency across different blender packages in AUR.

pkgver() { cd "$srcdir/blender" printf "2.81.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" }

This would make repology versions report more usable

thanks ;)

fbrennan commented on 2019-01-17 08:20

Thanks guys, I'm working on getting it to build myself with the new changes. A state of flux is an understatement, the new development branch differs significantly from the old one so please allow time for things to stabilize :-)

rigred commented on 2018-12-29 18:36

This is now no longer the blender-2.79 branch. Recently blender dves have moved the blender-2.8 code into master (this PKGBUILD compiles from master) and the PKGBUILD and build options haven't been updated yet.

Things are currently in a state of flux so it may take a while to get things worked out.

seo.disparate commented on 2018-12-25 08:24

I got this to build by adding the following changes to the PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index [`e828e21`](https://aur.archlinux.org/cgit/aur.git/commit/?h=blender-git&id=e828e21)..8fd245c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('i686' 'x86_64')
 url="<http://blender.org/>"
 depends=('libgl' 'python' 'desktop-file-utils' 'hicolor-icon-theme'
          'ffmpeg' 'fftw' 'openal' 'freetype2' 'libxi' 'openimageio' 'opencolorio'
-         'openshadinglanguage' 'libtiff' 'libpng')
+         'openshadinglanguage' 'libtiff' 'libpng' 'python-numpy')
 optdepends=('cuda: CUDA support in Cycles')
 makedepends=('git' 'cmake' 'boost' 'mesa')
 provides=('blender')
@@ -65,6 +65,7 @@ build() {
         -DWITH_PYTHON_INSTALL=OFF \
         -DPYTHON_VERSION=3.7m \
         -DWITH_MOD_OCEANSIM=ON \
+        -DPYTHON_NUMPY_PATH=/usr/lib/python3.7/site-packages \
         $_EXTRAOPTS
   make
 }

Note I'm not sure if python-numpy should be depends or make-depends, so I added it as depends in the diff.

agapito commented on 2018-12-25 06:36

Can´t build:

[ 93%] Building CXX object source/blender/freestyle/CMakeFiles/bf_freestyle.dir/intern/winged_edge/WXEdgeBuilder.cpp.o [ 93%] Building CXX object source/blender/freestyle/CMakeFiles/bf_freestyle.dir/intern/winged_edge/WingedEdgeBuilder.cpp.o [ 93%] Linking CXX static library ../../../lib/libbf_freestyle.a [ 93%] Built target bf_freestyle make: *** [Makefile:163: all] Error 2