Package Details: blabel 1.03-3

Git Clone URL: https://aur.archlinux.org/blabel.git (read-only, click to copy)
Package Base: blabel
Description: A Linux labeling program for Brother P-touch series
Upstream URL: https://apz.fi/blabel
Licenses: PerlArtistic
Groups: office
Provides: blabel
Submitter: Tom_ch
Maintainer: jakeobsen
Last Packager: jakeobsen
Votes: 5
Popularity: 0.000672
First Submitted: 2015-12-22 11:29
Last Updated: 2020-05-01 12:42

Pinned Comments

jakeobsen commented on 2020-03-30 22:35

Hi, I've updated the package to the latest version, and will keep it up to date in the future :) Happy labeling!

Please be aware the dependencies have changed for blabel, and that you install perl-net-cups from AUR.

How to fix CUPS.xs:15:11: fatal error: cupsfilters/image.h: No such file or directory

If perl-net-cups fails with the fatal error mentioned above, then you need to install cups-filters to fix it. I have already requested the maintainer of perl-net-cups to update his package with this dependency.

Latest Comments

1 2 Next › Last »

jakeobsen commented on 2020-05-01 12:52

@bofh1337 Thanks for the report, I have added perl-gd as a dependency to the package. Good to see that you resolved your issue.

bofh1337 commented on 2020-05-01 08:29

@Alpha_Seven I got gd installed, but perl-gd was not installed. Installing it fixed the problem. So its a missing dependency i guess. Thank you.

I already tried installing gd with cpan and that doesn´t worked.

Alpha_Seven commented on 2020-05-01 08:06

@bofh1337 Do you have GD installed? On my computer I find:

$ sudo pacman -Q|egrep "^gd |perl-gd"

gd 2.3.0-1

perl-gd 2.71-1

bofh1337 commented on 2020-05-01 07:51

blabel stopped printing in my case. It seems to be missing the GD module:

ctive printer: PT-2430PC Can't locate GD.pm in @INC (you may need to install the GD module) (@INC contains: /usr/lib/perl5/5.30/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.30/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.30/core_perl /usr/share/perl5/core_perl) at /usr/bin/blabel-print line 9. BEGIN failed--compilation aborted at /usr/bin/blabel-print line 9.

jakeobsen commented on 2020-04-03 10:47

@Alpha_Seven Packages installed from the AUR, which have dependencies on other packages in the AUR, does not install those dependencies automatically. You'll have to resolve those yourself. Only packages in the community repo is installed automatically when you install the blabel package. In this case perl-net-cups is an AUR dependency and has to be resolved manually.

Alpha_Seven commented on 2020-04-03 08:56

@jakeobsen I thought it was blabel's job to resolve that dependency, i. e. to install the package needed. I'll install perl-net-cups manually now. Thanks for your advice!

jakeobsen commented on 2020-04-02 20:57

@Alpha_Seven it seems that you have a missing dependency, you need to install the AUR package perl-net-cups as it's a new dependency for blabel.

Alpha_Seven commented on 2020-04-02 10:20

Great tool, which I've been using for many years. I hope, this is the right place for my request.

Today my Manjaro machine wants to update blabel and pygtk packages (nothing else). The build process fails with:

(…) ==> Tidying install... -> Removing libtool files... -> Purging unwanted files... -> Removing static library files... -> Stripping unneeded symbols from binaries and libraries... -> Compressing man and info pages... ==> Checking for packaging issues... ==> Creating package "pygtk"... -> Generating .PKGINFO file... -> Generating .BUILDINFO file... -> Generating .MTREE file... -> Compressing package... ==> Leaving fakeroot environment. ==> Finished making: pygtk 2.24.0-11 (Do 02 Apr 2020 11:51:37 CEST) ==> Cleaning up...

Checking keyring... Checking integrity... Loading packages files... Checking file conflicts... Checking available disk space... Upgrading pygtk (2.24.0-10 -> 2.24.0-11)...

Building blabel... ==> Making package: blabel 1.01-1 (Do 02 Apr 2020 11:51:41 CEST) ==> Checking runtime dependencies... ==> Missing dependencies: -> perl-net-cups ==> Checking buildtime dependencies... ==> ERROR: Could not resolve all dependencies.

jakeobsen commented on 2020-03-30 22:35

Hi, I've updated the package to the latest version, and will keep it up to date in the future :) Happy labeling!

Please be aware the dependencies have changed for blabel, and that you install perl-net-cups from AUR.

How to fix CUPS.xs:15:11: fatal error: cupsfilters/image.h: No such file or directory

If perl-net-cups fails with the fatal error mentioned above, then you need to install cups-filters to fix it. I have already requested the maintainer of perl-net-cups to update his package with this dependency.

apz commented on 2020-03-11 14:47

This series 0 package is out of date, for GTK3 enabled version see the series 1.00 of the software.