Package Details: bjumblr.lv2-git 1.4.2.r0.gfd90fae-2

Git Clone URL: https://aur.archlinux.org/bjumblr.lv2-git.git (read-only, click to copy)
Package Base: bjumblr.lv2-git
Description: A pattern-controlled audio stream re-sequencer LV2 plugin (git version)
Upstream URL: https://github.com/sjaehn/BJumblr
Keywords: slicer
Licenses: GPL3
Groups: lv2-plugins, pro-audio
Conflicts: bjumblr, bjumblr.lv2
Provides: bjumblr, bjumblr=1.4.2, bjumblr.lv2, bjumblr.lv2=1.4.2
Submitter: milk
Maintainer: milk (SpotlightKid)
Last Packager: SpotlightKid
Votes: 0
Popularity: 0.000000
First Submitted: 2020-01-20 19:39
Last Updated: 2020-08-24 22:43

Latest Comments

SpotlightKid commented on 2020-08-24 21:49

@rcrath: done

rcrath commented on 2020-08-24 21:12

plz add lv2lint as a dependency.

milk commented on 2020-06-15 06:38

Hi Ralf. This was a bug upstream, should be fixed by now. You can confirm if this is the case next time by git cloning the project repo and trying to build it manually.

Ralf_Mardorf commented on 2020-05-18 07:07

$ makepkg -s
[snip]
==> Updated version: bjumblr.lv2-git r167.7a24047-1
==> Starting build()...
Build BJumblr.lv2 DSP...Build BJumblr.lv2 GUI...src/BJumblr.cpp: In constructor ‘BJumblr::BJumblr(double, const LV2_Feature* const*)’:
src/BJumblr.cpp:70:21: error: ‘invalid_argument’ is not a member of ‘std’
   70 |  if (!m) throw std::invalid_argument ("BJumblr.lv2: Host does not support urid:map.");
      |                     ^~~~~~~~~~~~~~~~
src/BJumblr.cpp:71:34: error: ‘invalid_argument’ is not a member of ‘std’
   71 |  if (!workerSchedule) throw std::invalid_argument ("BJumblr.lv2: Host does not support work:schedule.");
      |                                  ^~~~~~~~~~~~~~~~
src/BJumblr.cpp: In constructor ‘BJumblr::Sample::Sample(const char*)’:
src/BJumblr.cpp:104:50: error: ‘invalid_argument’ is not a member of ‘std’
  104 |         if (!sndfile || !info.frames) throw std::invalid_argument("BJumblr.lv2: Can't open " + std::string(samplepath) + ".");
      |                                                  ^~~~~~~~~~~~~~~~
src/BJumblr.cpp: In member function ‘LV2_State_Status BJumblr::state_restore(LV2_State_Retrieve_Function, LV2_State_Handle, uint32_t, const LV2_Feature* const*)’:
src/BJumblr.cpp:701:15: error: ‘invalid_argument’ in namespace ‘std’ does not name a type
  701 |   catch (std::invalid_argument &ia)
      |               ^~~~~~~~~~~~~~~~
src/BJumblr.cpp:703:29: error: ‘ia’ was not declared in this scope
  703 |    fprintf (stderr, "%s\n", ia.what());
      |                             ^~
src/BJumblr.cpp: In member function ‘LV2_Worker_Status BJumblr::work(LV2_Worker_Respond_Function, LV2_Worker_Respond_Handle, uint32_t, const void*)’:
src/BJumblr.cpp:842:17: error: ‘invalid_argument’ in namespace ‘std’ does not name a type
  842 |     catch (std::invalid_argument &ia)
      |                 ^~~~~~~~~~~~~~~~
src/BJumblr.cpp:844:31: error: ‘ia’ was not declared in this scope
  844 |      fprintf (stderr, "%s\n", ia.what());
      |                               ^~
make: *** [makefile:109: BJumblr.so] Error 1
[snip]