Package Details: bitwarden_rs 1.10.0-3

Git Clone URL: https://aur.archlinux.org/bitwarden_rs.git (read-only)
Package Base: bitwarden_rs
Description: An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
Upstream URL: https://github.com/dani-garcia/bitwarden_rs
Keywords: bitwarden manager password passwordmanager rust selfhosted server
Licenses: GPL3
Conflicts: bitwarden_rs-git, bitwarden_rs-mysql
Submitter: mqs
Maintainer: mqs
Last Packager: mqs
Votes: 7
Popularity: 0.940888
First Submitted: 2018-07-13 15:29
Last Updated: 2019-09-13 22:04

Latest Comments

1 2 Next › Last »

dcelasun commented on 2019-08-28 21:22

Done! https://aur.archlinux.org/packages/bitwarden_rs-mysql

@mqs: Would you mind adding conflicts=(bitwarden_rs-mysql) to this package?

mqs commented on 2019-08-28 21:01

sure, thanks!

PS:That sounds a bit like I was searching for maintainers of the new package even though I'm not using it :D

dcelasun commented on 2019-08-28 20:56

@mqs: Thanks. If you don't want to maintain a mysql version, I'm willing to put up a package and maintain it myself. Does that sound ok?

mqs commented on 2019-08-28 20:52

@dcelasun:

Conditional deps are not supported by .SRCINFO as far as I can tell...

There would also be the issue of the .service file having to "depend" on the mysql service etc... an extra package is far easier to provide and does not create as much overhead as you may think.

But I have to say it again: I really don't want to run the mysql version myself so I can't "fully" support it. I can only throw an AUR package over the fence and hope it works because it compiled successfully. If that's enough for you, I'll be happy to do it.

dcelasun commented on 2019-08-28 20:46

Yes please, I'd love a mysql version.

but then the package would have to include dependencies for both mysql and sqlite

You don't need to do that. Just make depends=() conditional on the env variable as well and let it default to sqlite.

mqs commented on 2019-08-28 20:32

The last version introduced support for MySQL/MariaDB. Are there any users who would be interested in a bitwarden_rs with the mysql backend?

I can't provide a binary (or a package(*)) which provides both backends and I chose to continue using sqlite myself, but if there are some users who'd like a mysql package I can try to make a PKGBUILD which compiles at least and works with the vault.

(*) A single binary with both is not possible at the moment because only one backend is compiled in. Compiling only one of them could be solveable via a environment variable or a prompt but even that is not exactly the best way, but then the package would have to include dependencies for both mysql and sqlite even though it only needs one which creates needless hassle.

mqs commented on 2018-09-23 15:16

@ChrisMorgan Fixed, thanks!

Edit: v1.2.0 was just released, working on it

ChrisMorgan commented on 2018-09-23 13:33

Now failing to build because https://github.com/tyranron/lettre?branch=upgrade-to-native-tls-0-2#644b1e59 doesn’t exist.

I’ve requested a new upstream release 1.1.1 to go with openssl 1.1.1.

mqs commented on 2018-09-20 15:14

Sorry, I thought I might be the only one having those problems and wanted to wait till someone says something.

I'll try the openssl1.1.1 branch and will include a patch if it works, if it doesn't, i'll workaround by using openssl1.0 (I already tested that but didn't want to "downgrade" the openssl version from 1.1.0 to 1.0.2 for eceryone unless neccessary)

Edit:pushed an update, roughly equivalent to the upstream openssl-fix - commit. This will tell cargo to use more recent versions of lettre, native-tls and reqwest, resulting in rust-openssl using openssl v1.1.1 .

ChrisMorgan commented on 2018-09-20 13:54

bitwarden_rs 1.1.0 won’t build with OpenSSL 1.1.1, and the core repository updated openssl to 1.1.1-1 a day before you released bitwarden_rs 1.1.0-1 here (I guess you hadn’t updated before pushing).

https://github.com/dani-garcia/bitwarden_rs/issues/193 is tracking unbreaking OpenSSL 1.1.1.

I guess you could patch it somehow, but I wouldn’t bother; it’ll probably be sorted out fairly quickly. Any new users should just install the previous release instead.