Package Details: bitwarden_rs-sqlite 1.20.0-1

Git Clone URL: https://aur.archlinux.org/bitwarden_rs-sqlite.git (read-only, click to copy)
Package Base: bitwarden_rs-sqlite
Description: An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
Upstream URL: https://github.com/dani-garcia/bitwarden_rs
Keywords: bitwarden manager password passwordmanager rust selfhosted server sqlite
Licenses: GPL3
Conflicts: bitwarden_rs, bitwarden_rs-git, bitwarden_rs-mysql, bitwarden_rs-postgresql
Submitter: mqs
Maintainer: None
Last Packager: mqs
Votes: 15
Popularity: 0.028867
First Submitted: 2020-12-09 14:53
Last Updated: 2021-04-16 14:44

Pinned Comments

mqs commented on 2020-12-09 15:14

FAQ

Q: Why was this package renamed?
A: Because the "old" name is now used for the multi-db bitwarden_rs package in the main archlinux repos. This is good because you don't have to compile it yourself anymore :)

Q: Why should I build and install this package even though there is community/bitwarden_rs?
A: This one only bundles sqlite support and can drop the dependencies on the other database libraries and is therefore a few megabytes smaller.

Q: Building this takes too long!
A: It does :) But there is nothing I can do. Make sure that you have enough memory/swap when building this on a raspberry pi or something similar. This much memory is not needed when you actually run the server.

Q: I have some other problem when I build&install this.
A: Post your problem in the comments below or in the bitwarden_rs forums first, even if your issue is in one of the official clients (android/ios app/browser plugin/etc), we will tell you if this is a limitation of bitwarden_rs or a bug in the official apps.

grawlinson commented on 2020-02-18 05:34

If any users are running this in a container (LXC, et al), the systemd service will not start. The line LimitNPROC=64 in the service file prevents the service from starting, as the following error shows:

Feb 18 05:29:10 staging-bitwarden systemd[1]: Started Bitwarden Server (Rust Edition).
Feb 18 05:29:10 staging-bitwarden systemd[49506]: bitwarden_rs.service: Failed to execute command: Resource temporarily unavailable
Feb 18 05:29:10 staging-bitwarden systemd[49506]: bitwarden_rs.service: Failed at step EXEC spawning /usr/bin/bitwarden_rs: Resource temporarily unavailable
Feb 18 05:29:10 staging-bitwarden systemd[1]: bitwarden_rs.service: Main process exited, code=exited, status=203/EXEC
Feb 18 05:29:10 staging-bitwarden systemd[1]: bitwarden_rs.service: Failed with result 'exit-code'.

Commenting out that particular line results in the service starting correctly.

Latest Comments

1 2 3 4 Next › Last »

mqs commented on 2020-12-09 15:14

FAQ

Q: Why was this package renamed?
A: Because the "old" name is now used for the multi-db bitwarden_rs package in the main archlinux repos. This is good because you don't have to compile it yourself anymore :)

Q: Why should I build and install this package even though there is community/bitwarden_rs?
A: This one only bundles sqlite support and can drop the dependencies on the other database libraries and is therefore a few megabytes smaller.

Q: Building this takes too long!
A: It does :) But there is nothing I can do. Make sure that you have enough memory/swap when building this on a raspberry pi or something similar. This much memory is not needed when you actually run the server.

Q: I have some other problem when I build&install this.
A: Post your problem in the comments below or in the bitwarden_rs forums first, even if your issue is in one of the official clients (android/ios app/browser plugin/etc), we will tell you if this is a limitation of bitwarden_rs or a bug in the official apps.

mqs commented on 2020-12-09 00:28

@polyzen, thank you very much for taking bitwarden_rs over to the community repo and maintaining it there :)

I'll probably rename it like you suggested. I'm not sure on how to proceed with the -git package but I'll figure something out :)

But I probably will lose some motivation if someone else suddenly does my work for me, so I can't guarantee to update this package for ever ;)

polyzen commented on 2020-11-24 10:00

Looks like you put a fair amount of work into this package -- thank you! I've added a multidb version of this to the repos. Please rename this to bitwarden_rs-sqlite if you'd like to continue maintaining it.

mqs commented on 2020-10-11 18:16

I thought about it a bit more and tried out some things.

Point 1 is almost entirely moot since the database can also run on a different machine. So depending on that in any way would be unnecessarily limiting and configuring the service file for that should be up to the user.

I'm currently building bitwarden_rs-git with a multi-db backend and tried out the dependencies. I noticed that -mysql and -postgresql depend on mysql/postgresql entirely, not only their client libraries which are necessary for building bitwarden_rs, which alleviates this issue a bit.

But on the other hand, mariadb-libs and postgresql-libs are also required at runtime, if you compiled the bitwarden_rs with it. That makes ~2MB more for the multidb-package as well as an additional ~30MB of mandatory libraries. I'm not sure if this is ok.

With those circumstances I'm more for the separate packages.

mqs commented on 2020-10-11 09:51

@bjo, @grawlinson In principle I am not against this, but there are some issues to remember.

  1. I would have liked to put Wants=mysqld.service (or the apropriate equivalent) into the service file for the database dependencies. But as it isn't included in the separate packages even now, I am leaving this out and only putting After=mysqld.service in, which should work even if mysql is not installed.

  2. Dependencies. I would have wanted to leave out the dependencies on mysql or postgresql for the sqlite packages for reasons of waste on the system. I can compromise on that if those are staying make dependencies and optional runtime dependencies, so that would not be an issue. Btw, mysql and postgresql are not runtime-dependencies of bitwarden_rs-{musql,postgresql}. Is this intentional?

  3. Binary size. I think this is not really an issue but lets not forget it.

Nevertheless, I would want to only make bitwarden_rs-git multi-db for now, to allow for testing and would try push the next bitwarden_rs release (not 1.17.0) with a multidb PKGBUILD.

grawlinson commented on 2020-10-10 21:08

That’s fantastic news. It means that this package (bitwarden_rs) can be the sole provider for all database backends.

bjo commented on 2020-10-10 19:47

1.17.0 has support for multiple databases at once:

Multiple database support, now you can compile with cargo build --features sqlite,mysql,postgresql or any combination of them.

So, do we still need the different PKGBUIlDs?

mqs commented on 2020-10-09 09:52

Apart from what grawlinson said, could you try to run

sudo -u bitwarden_rs bash
cd
cp /etc/bitwarden_rs.env .env
/usr/bin/bitwarden_rs

and see what it says? This should basically run bitwarden_rs without using systemd but with the same user permissions. If it does not fail(or fails differently) then the issue lies in the (possibly too) restrictive .service file I put together. If it also fails then the issue is in your configuration or setup.

It would help if you could put together how to reproduce your issue (what did you do after you installed the bitwarden_rs package?)

PS: Right, after the test above (which you can stop with ctrl+c) you might want to clean up the copy of the .env config file with rm .env.

grawlinson commented on 2020-10-09 08:24

@christian-arch: I've been using bitwarden_rs behind a reverse proxy (nginx) for TLS. I think that's what upstream has recommended.

What are the permissions on the certificate files? Do they actually exist?

christian-arch commented on 2020-10-08 23:31

I'm trying to setup bitwarden with HTTPS but when I try to start the service it exits with:

Oct 09 01:15:45 server bitwarden_rs[2201]: Error: I/O error while setting tls.certs:
Oct 09 01:15:45 server bitwarden_rs[2201]:     => Permission denied (os error 13)

I figure this has something to do with which user the service is running I tried changing the service's group and let that group read my cert files but still get the same error. I also tried to run the service as root but then I get:

Oct 09 01:26:20 server systemd[1]: bitwarden_rs.service: Main process exited, code=dumped, statu>
Oct 09 01:26:20 server systemd[1]: bitwarden_rs.service: Failed with result 'core-dump'.

Is anyone running bitwarden from this package with TLS enabled?