Package Details: bitwarden_rs-postgresql 1.14.1-1

Git Clone URL: https://aur.archlinux.org/bitwarden_rs-postgresql.git (read-only, click to copy)
Package Base: bitwarden_rs-postgresql
Description: An unofficial lightweight implementation of the bitwarden-server using rust and postgresql. Does NOT include the web-interface.
Upstream URL: https://github.com/dani-garcia/bitwarden_rs
Licenses: GPL3
Conflicts: bitwarden_rs, bitwarden_rs-git, bitwarden_rs-postgresql
Provides: bitwarden_rs
Submitter: dcelasun
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 2
Popularity: 0.198975
First Submitted: 2019-10-09 07:40
Last Updated: 2020-03-25 19:03

Latest Comments

oguresic commented on 2020-01-07 08:15

For aarch64 architecture I got the following compiling error in cargo:

linker stubs: file class ELFCLASSNONE incompatible with ELFCLASS64

It is due to binutils update from 2.32 to 2.33 and I assume the -fix-cortex-a53-835769 --fix-cortex-a53-843419 flags lead to an invalid operation.

To fix this downgrade to binutils 2.32 Version.

I had it in my /var/cache/pacman/pkg/binutils-2.32-1-aarch64.pkg.tar.xz and was able to rollback it by using pacman -U binutils-2.32-1-aarch64.pkg.tar.xz.

Siosm commented on 2020-01-05 18:06

Suggested update for 1.13.1: https://github.com/Siosm/archlinux-bitwarden_rs-postgresql/commit/8862da33b998059ba593e17052b03b0b9d457ad6

djmattyg007 commented on 2019-12-08 02:22

Please follow the lead of the main bitwarden_rs package by adding '--locked' to the cargo build command.