Package Details: bitw-git r53.aa676ad-2

Git Clone URL: https://aur.archlinux.org/bitw-git.git (read-only, click to copy)
Package Base: bitw-git
Description: Minimalist BitWarden client with Secret Service API implementation - git version
Upstream URL: https://github.com/mvdan/bitw
Keywords: bit bitwarden dbus keyring libsecret manager password secret warden
Licenses: BSD
Conflicts: bitw
Provides: bitw, org.freedesktop.secrets
Submitter: dpeukert
Maintainer: dpeukert
Last Packager: dpeukert
Votes: 3
Popularity: 0.037865
First Submitted: 2019-06-25 22:39
Last Updated: 2020-06-06 20:17

Dependencies (5)

Required by (39)

Sources (1)

Pinned Comments

dpeukert commented on 2019-12-08 22:08

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/master/bitw-git

Latest Comments

1 2 Next › Last »

dpeukert commented on 2020-03-14 12:32

@mvdan Oops, I've missed that, I'll mark golang-rsc-2fa as a checkdepends. The utilities are marked as optdepends for golang-github-atotto-clipboard, which means they will be presented at install time, so we don't need them as optdepends here. I'll pin a comment here just to be sure. Thanks for the clarification.

mvdan commented on 2020-03-14 11:58

Just to clarify, though - 2fa is only a test dependency, not a run-time one. So if anything, the clipboard deps are optional check dependencies, not optional run-time or build dependencies. I assume there's no way to clarify that in the PKGBUILD.

mvdan commented on 2020-03-14 11:57

@dpeukert OK, now I get the full picture. This is somewhat confusing, as we end up adding deps here which are duplicate from an indirect package dependency.

dpeukert commented on 2020-03-14 11:52

@mvdan Hi, the test itself is only relevant to https://aur.archlinux.org/packages/golang-github-atotto-clipboard, I've also added the optdepends there, but from my understanding, bitw uses the -clip flag of 2fa, which in turn uses the copy functionality of atotto/clipboard, which requires one of the command line utilities at runtime. The PKGBUILD isn't running all the tests by itself, the dependencies have been packaged as separate packages and each of them is running its own tests.

mvdan commented on 2020-03-14 11:34

Hi, upstream here - I'm a bit confused by the comments below about TestCopyAndPaste. The test is not part of the project; it's only part of an indirect dependency, since we depend on a 2fa tool that depends on it: https://github.com/atotto/clipboard/blob/master/clipboard_test.go

Still, the PKGBUILD should not be running tests for all direct and indirect dependencies. If that's happening, I think you should fix that instead of adding more optional dependencies.

dpeukert commented on 2020-03-14 10:55

@felinira Hmm, looks like there isn't really a way to do that. I've gone ahead and added all of them as optdepends.

felinira commented on 2020-03-13 17:58

I got an error installing this because I didn't have a clipboard utility installed. It failed in check(). I don't really know if it is possible to depend on just any one of these. Probably not.

The message was:

TestCopyAndPaste: clipboard_test.go:18: No clipboard utilities available. Please install xsel, xclip, wl-clipboard or Termux:API add-on for termux-clipboard-get/set.
--- FAIL: TestCopyAndPaste (0.00s)

dpeukert commented on 2019-12-08 22:08

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/master/bitw-git

dpeukert commented on 2019-11-20 15:55

@Omar007 Thanks for the heads-up again :), I'll fix the PKGBUILD tonight.

Omar007 commented on 2019-11-18 12:48

The 'LICENSE.google' file has been removed upstream so the PKGBUILD currently fails as it currently attempts to copy it into the package. Line 28 should be removed.