Package Details: betaflight-configurator 10.6.0-2

Git Clone URL: https://aur.archlinux.org/betaflight-configurator.git (read-only, click to copy)
Package Base: betaflight-configurator
Description: Crossplatform configuration tool for the Betaflight flight control system
Upstream URL: https://github.com/betaflight/betaflight-configurator
Licenses: GPL3
Submitter: FryDay
Maintainer: Jake
Last Packager: Jake
Votes: 11
Popularity: 1.84
First Submitted: 2018-01-24 18:06
Last Updated: 2019-12-15 12:01

Latest Comments

1 2 3 Next › Last »

neo2001 commented on 2019-12-15 15:27

@Jake: Confirmed! Works fine now (again)!

Thank you! :)

Jake commented on 2019-12-15 12:05

Yes, i found that the issue came with the nwjs update to 0.42.4, where they enabled NW2 per default: https://nwjs.io/blog/nw2-mode/

Added a flag to disable it in the start script now, that should fix it, please install the new pkrel and let me know if it works @neo2001.

neo2001 commented on 2019-12-15 11:19

I've just removed the package I previously build manually and reinstalled/rebuild the package using Octopi. All seemed fine, but now both yellow round buttons are greyed out all the time. I can still access the firmware flashing interface by selecting the menu item on the left, but since there is no other button for the configurator, I can't access it. Tried to remove all user settings and plugged in different targets/devices.

Same package build a few days ago on my other machine works still fine.

Googled a bit and found something about the Chrome version having this issue, but this is the standalone version. Just wanted to ask if anyone experienced the same issue recently before asking upstream?

neo2001 commented on 2019-11-18 16:20

Thank you for the explanation. I did indeed run makepkg -s "manually" since I wanted to keep the Git repo for faster updates/rebuilds. I like to do this for Git-based AUR packages.

Jake commented on 2019-11-17 21:52

neo2001: Your AUR helper needs to resolve/build the deps before installation. Seems like your are doing something like makepkg -s and pacman alone can't resolve it of course, because the ffmepg codecs package is also only in the AUR.

neo2001 commented on 2019-11-06 12:49

Hello and thank you for providing these packages!

I get the following errors when I want to build/install the betaflight-configurator and the blackbox-explorer:

=> WARNING: PACKAGER should have the format 'Example Name email@address.invalid' ==> Making package: blackbox-explorer 3.4.0-1 (Mi 06 Nov 2019 13:43:37 CET) ==> Checking runtime dependencies... ==> Installing missing dependencies... error: target not found: nwjs-ffmpeg-codecs-bin ==> ERROR: 'pacman' failed to install missing dependencies. ==> Missing dependencies: -> nwjs-ffmpeg-codecs-bin ==> Checking buildtime dependencies... ==> ERROR: Could not resolve all dependencies.

After manually installing njws-bin and nwjs-ffmpeg-codecs-bin from AUR everything works fine.

I'm pretty sure I installed the same packages on my other machine without any errors like that, so the it could be a local issue...

Any ideas where to look? :-)

Jake commented on 2019-04-11 13:48

@andrej: Didn't think that someone needs to start this with arguments, but apparently that was wrong, really should add such things always in the beginning ;)
It is changed now with the update to 10.5.0 (supporting the new BF 4.0!)

andrej commented on 2019-03-24 03:34

Thanks for maintaining this. It would be helpful to pass command-line arguments in the launcher script. I tried to run multiple instances of the configurator, for which you have to set --user-data-dir, and it didn't work at all, as described on GitHub. :-)

Jake commented on 2018-09-06 13:37

Sure, done.

btreecat commented on 2018-09-05 17:11

Can the workaround be included in the mean time so the package is not broken?