Package Details: beancount-git 2.3.3.r451.gf9481591-1

Git Clone URL: https://aur.archlinux.org/beancount-git.git (read-only, click to copy)
Package Base: beancount-git
Description: Double-Entry Accounting from Text Input
Upstream URL: http://furius.ca/beancount/
Licenses: GPL
Conflicts: beancount, beancount-hg
Provides: beancount=2.3.3, ledgerhub-hg
Replaces: beancount-hg, ledgerhub-hg
Submitter: aperez
Maintainer: aperez
Last Packager: aperez
Votes: 9
Popularity: 0.000413
First Submitted: 2020-07-22 14:13
Last Updated: 2021-02-25 19:11

Latest Comments

1 2 Next › Last »

aclindsa commented on 2021-06-05 02:22

@aparez I don't believe your latest change had the desired effect - it is still pulling the v3 version of beancount (labeled as 'unstable' still) instead of the v2 branch. I believe line 9 in the PKGBUILD would need to be updated to be:

source=("${pkgname}::git+https://github.com/beancount/beancount/#branch=v2")

aperez commented on 2021-02-25 19:13

I have just pushed a small update, let me know if any issues remain for you. Unfortunately, I do not use Beancount anymore so I have not been maintaining the PKGBUILD updated. If somebody else would like to take maintain the package, I can pass it over or add them as co-maintainers—let me know!

aclindsa commented on 2021-02-25 12:35

Beancount now has two primary versions, v2 and v3. Is your intention with this package to always follow the latest, even if it breaks compatibility with v2, or to follow the v2 branch?

If your intention is to stick with v2 for now, you can change the git import URL to: git+https://github.com/beancount/beancount/#branch=v2

AlphaJack commented on 2021-02-07 00:38

python-pytest seems to be a required dependency

Also I get

Traceback (most recent call last):
  File "/bin/fava", line 5, in <module>
    from fava.cli import main
  File "/usr/lib/python3.9/site-packages/fava/cli.py", line 11, in <module>
    from fava.application import app
  File "/usr/lib/python3.9/site-packages/fava/application.py", line 40, in <module>
    from fava import template_filters
  File "/usr/lib/python3.9/site-packages/fava/template_filters.py", line 21, in <module>
    from fava.context import g
  File "/usr/lib/python3.9/site-packages/fava/context.py", line 6, in <module>
    from fava.core import FavaLedger
  File "/usr/lib/python3.9/site-packages/fava/core/__init__.py", line 58, in <module>
    from fava.core.ingest import IngestModule
  File "/usr/lib/python3.9/site-packages/fava/core/ingest.py", line 12, in <module>
    from beancount.ingest import cache  # type: ignore
ModuleNotFoundError: No module named 'beancount.ingest'

when starting Fava with this version of beancount installed, the non-git version works fine

kris7t commented on 2020-12-28 21:12

Looks like the bean-price utility was recently moved to another repository: https://github.com/beancount/beancount/commit/9e26d21c1848e89c6f63b76b96141adddb110a0d

I created an AUR package for it: https://aur.archlinux.org/packages/beanprice-git/

@aperez: if you want, I can set you as the maintainer of the new package.

aperez commented on 2020-07-22 14:15

This package is replaced by beancount-githttps://aur.archlinux.org/packages/beancount-git/

xuhcc commented on 2020-05-23 12:05

Beancount moved to GitHub: https://github.com/beancount/beancount

aperez commented on 2019-01-07 10:23

@cejota: I have already pushed the changes. That was a really good suggestion, thanks!

cejota commented on 2019-01-06 19:19

You could change the pkgver() to make it compatible with other programs requiring minimum versions of beancount:

pkgver() {
  cd "${pkgname}"
  hg log -r . --template '{latesttag}-{latesttagdistance}-{node|short}' | sed 's/^\([^-]*\)-\([^-]*\)-/\1.r\2./'
}

And then you could provide the correct version number in provides:

provides=('ledgerhub-hg' "beancount=${pkgver%%.r*}")

aperez commented on 2018-03-05 12:13

@wzyboy: I have added the conflicts/provides as suggested. Thanks for the tip!