Package Details: beaker-browser-bin 0.8.8-1

Git Clone URL: https://aur.archlinux.org/beaker-browser-bin.git (read-only, click to copy)
Package Base: beaker-browser-bin
Description: Peer-to-peer browser with tools to create and host websites
Upstream URL: https://beakerbrowser.com/
Licenses: Modified MIT License (MIT)
Provides: beaker-browser, beakerbrowser
Submitter: jeancf
Maintainer: jeancf
Last Packager: jeancf
Votes: 11
Popularity: 0.017569
First Submitted: 2018-01-03 15:20
Last Updated: 2019-04-04 09:13

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

pegasus commented on 2018-08-17 11:38

So when the package never gets updated upstream, and never works on Arch again, it's still up to date? Yeah, no.

But I've gone ahead and found a fix that might suit your minimal effort standards.

beaker-browser-0.8.0-prerelease.7-x86_64.AppImage --appimage-extract

move the entirety of squashfs-root to /opt/beaker-browser

modify /usr/bin/beaker-browser thus:

# Launch AppImage application
/usr/bin/electron /opt/beaker-browser/app/resources/app.asar

Add electron to the dependencies. Install other files as normal.

jeancf commented on 2018-08-17 07:08

If I can do something to the AppImage to fix the issue that you are experiencing I will gladly do it. I have no interest in building this app from source.

Again, this package is not out-of-date so please stop flagging it as such. An AUR package is out-of-date when there is a more recent release from upstream. It is not the case here.

pegasus commented on 2018-08-16 19:20

I do have a valid email address, and it is attached to this account.

You do realize you can just leave it flagged out of date until upstream provides a fix? Saying "It's up-to-date with upstream" is disingenuous. Upstream is also out-of-date.

Not to mention the fact that beaker-brower (sans -bin) is flagged out of date, and a rather old version, and I see no evidence that they actually build it themselves.

If you want to talk about ways to make the -git branch of this package, hit me up, I have ideas.

jeancf commented on 2018-08-16 19:07

@pegasus who keeps flagging this package out of date but does not have a valid email address to discuss the issue:

This is a "bin" package that is up to date with the binary release (AppImage) on the beaker browser github site. There is nothing I can do to fix the issue that you are experiencing but wait for a new binary release from upstream.

There is a beaker-browser package on AUR that seems to build the package. They should be able to accommodate a patch if one exists.

Powersource commented on 2018-08-16 19:04

Yes changing that variable doesn't seem to affect the appimage.

jeancf commented on 2018-08-16 18:43

I added export ELECTRON_PATH=/usr/bin/electron to the launch script but it should not make a difference as the AppImage does not have an external dependency on electron.

Powersource commented on 2018-08-16 18:15

Related issue with at least a fix for running from source https://github.com/beakerbrowser/beaker/issues/992

jeancf commented on 2018-08-16 18:10

There is not much I can do to help. This package simply installs the .AppImage package from the beaker browser github site. An AppImage is supposed to be fully self-contained with no external dependencies.

Can you try downloading and running the AppImage from https://github.com/beakerbrowser/beaker/releases/download/0.8.0-prerelease.7/beaker-browser-0.8.0-prerelease.7-x86_64.AppImage and check if it also segfaults?

Powersource commented on 2018-08-16 17:14

Getting the same issue on my other computer. It's worked on both computers before.

jeancf commented on 2018-08-16 17:12

I am not experiencing any issue myself (Manjaro/Cinnamon). Has the latest version ever worked on your machine?