Package Details: bcwc-pcie-git 0.5.7.r0.g82626d4-1

Git Clone URL: https://aur.archlinux.org/bcwc-pcie-git.git (read-only, click to copy)
Package Base: bcwc-pcie-git
Description: Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam.
Upstream URL: https://github.com/patjak/bcwc_pcie
Keywords: driver facetime macbook webcam
Licenses: unknown
Provides: bcwc-pcie, bcwc-pcie-dkms
Replaces: bcwc-pcie, bcwc-pcie-dkms
Submitter: WhyNotHugo
Maintainer: ivladak
Last Packager: ivladak
Votes: 26
Popularity: 0.94
First Submitted: 2015-12-23 14:14
Last Updated: 2021-01-21 21:04

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

m3thodic commented on 2016-10-11 07:59

Anyone that's having issues getting this to compile on 4.8 branches, use this PKGBUILD and patch until the pull request I generated the diff from is merged (tested and confirmed on linux-macbook kernel 4.8.1):

PKGBUILD: https://gist.github.com/tonylambiris/cc215849f8c1467d88b7d1ddda78546a
fix-build-4.8.1.patch: https://gist.github.com/tonylambiris/2e4485e09eac8585485d597406531877

iamazat commented on 2016-10-10 18:48

For those who need this in 4.8 (if it will not be merged for awhile):
https://github.com/patjak/bcwc_pcie/pull/102

WhyNotHugo commented on 2016-05-31 23:54

PKGBUILD updated.

Jack12816 commented on 2016-05-31 18:20

This package is great, but it lacks support for custom kernel builds. Please consider this patch: (https://wiki.archlinux.org/index.php/Compile_kernel_module#Module_installation there is an easy way to get the extra modules path)

--- a/PKGBUILD 2016-05-31 20:15:34.687067886 +0200
+++ b/PKGBUILD 2016-05-31 20:16:17.142824626 +0200
@@ -33,9 +33,9 @@
package() {
cd "$srcdir/$pkgname"

- KERNEL_VERSION=$(uname -r | cut -d '.' -f 1,2)
+ EXTRA_MODULES=$(readlink -f /usr/lib/modules/`uname -r`/extramodules)
install -Dm 644 facetimehd.ko.gz \
- "$pkgdir/usr/lib/modules/extramodules-${KERNEL_VERSION}-ARCH/facetimehd.ko.gz"
+ "$pkgdir/${EXTRA_MODULES}/facetimehd.ko.gz"
install -Dm 644 "$srcdir/bcwc-pcie.modprobe.conf" \
"$pkgdir/etc/modprobe.d/bcwc-pcie.conf"
install -Dm 644 "$srcdir/bcwc-pcie.modules-load.conf" \

gokcen commented on 2016-05-14 07:05

bcwc-pcie-git package also gives following error:

Direct firmware load for facetimehd/1871_01XX.dat failed with error -2

but unlike bcwc-pcie-dkms, it works fine.

A.J commented on 2016-03-23 10:27

here is what i found in dmesg :

[ 2113.241563] facetimehd 0000:02:00.0: firmware: facetimehd/1871_01XX.dat will not be loaded

A.J commented on 2016-03-23 03:29

pacman build it fine , but the driver isn't working with cheese or any application .

WhyNotHugo commented on 2016-03-22 14:09

Looks like something changed regarding dkms packages since 4.5, but it *did* build okay for me. What issue did you get?

A.J commented on 2016-03-22 03:53

doesn't build correctly after kernel update .

EDIT : apparently it is a known issue with kernel 4.5 .

trusktr commented on 2016-02-26 01:19

Ah, for some reason PKGBUILD had all permissions removed, so chmod u+rw worked.