Package Details: battlescribe 2.03.10-1

Git Clone URL: https://aur.archlinux.org/battlescribe.git (read-only)
Package Base: battlescribe
Description: An army list builder for table-top games.
Upstream URL: http://battlescribe.net/?tab=downloads
Keywords: army java table-top
Licenses: custom
Submitter: ClawOfLight
Maintainer: ClawOfLight
Last Packager: ClawOfLight
Votes: 4
Popularity: 0.22
First Submitted: 2016-06-12 13:38
Last Updated: 2019-11-28 11:35

Pinned Comments

ClawOfLight commented on 2019-11-23 08:46

I could write a script that scrapes the home page, but it would not work due to his regularly changing the html *and generating the download URL in Javascript*!
The real problem is that upstream refuses to provide an RSS feed for releases or proper version information on the home page.

No need to comment every time though - simply flag this package out of date, I will push the update within a day.

Latest Comments

ClawOfLight commented on 2019-11-23 08:46

I could write a script that scrapes the home page, but it would not work due to his regularly changing the html *and generating the download URL in Javascript*!
The real problem is that upstream refuses to provide an RSS feed for releases or proper version information on the home page.

No need to comment every time though - simply flag this package out of date, I will push the update within a day.

Eric_D commented on 2019-11-22 15:27

Hello,

Same issue as last time, the correct version now is 2.03.08.

Any way we could see how to automate this ?

Eric_D commented on 2019-11-04 11:07

Trying too upgrade:

==> ERROR: Failure while downloading http://battlescribe.net/files/BattleScribe_2.03.04_Multi.zip Aborting...

The latest version now seems to be 2.03.06.

es02 commented on 2019-10-25 04:30

2.03.03 is broken (dead link), use the following PKGBUILD instead: https://github.com/es02/AUR_Battlescribe_update/blob/master/PKGBUILD

ClawOfLight commented on 2019-09-18 20:44

Sorry, I had rebuilt it while on vacation but forgot to push the change to AUR.

Eric_D commented on 2019-09-18 20:15

Hello, Any chance you could please update this package to 2.03.01 ? If I'm not mistaken, this change should be enough:

https://github.com/edalongeville/AUR_Battlescribe_update/blob/master/PKGBUILD

(I just changed the version number and md5sum)

hav3lock commented on 2017-06-23 03:09

Could you please install `BattleScribe.sh` to `/usr/bin/battlescribe` instead of `/usr/share/java/battlescribe`? That way it'll be in the path and easier to call from the command-line.