Package Details: bat-cat-git r205.c91511c-1

Git Clone URL: https://aur.archlinux.org/bat-cat-git.git (read-only, click to copy)
Package Base: bat-cat-git
Description: A cat(1) clone with wings.
Upstream URL: https://github.com/sharkdp/bat
Licenses: Apache-2.0
Provides: bat
Submitter: kltx
Maintainer: kltx
Last Packager: kltx
Votes: 6
Popularity: 0.51
First Submitted: 2018-06-04 15:05
Last Updated: 2020-02-01 14:09

Required by (6)

Sources (1)

Latest Comments

jamesmcm commented on 2020-05-10 15:53

Please add the missing clang dependency :)

wommel commented on 2020-03-12 17:06

this should conflict with bat

kltx commented on 2020-02-01 14:11

Should be fixed now

Trollwut commented on 2020-02-01 10:49

thanks for the quick support!

@balki am I right to assume that the mentioned recompiling of its assets is currently not in the community package?

balki commented on 2020-01-31 18:34

FYI all, the package is now available in community now.

https://www.archlinux.org/packages/community/x86_64/bat/

Trollwut commented on 2020-01-31 15:16

Hey @kitx,

the git package bundles some assets which are compiled via a shell script. This is not the case in this AUR package.

I asked the dev about the new published themes not in the package and he responded that the AUR package just should run an additional command :)

Would you implement this command?

Here's the issue: https://github.com/sharkdp/bat/issues/814

Trollwut commented on 2019-12-05 14:36

got the same error as @balki before me. I installed the clang package and it compiled nice for me :)

TL;DR clang is needed as a dependency

balki commented on 2019-08-11 02:19

Not working. Likely dependency problem. :(

==> Starting build()... Compiling onig_sys v69.2.0 error: failed to run custom build command for onig_sys v69.2.0

Caused by: process didn't exit successfully: /home/balki/aur/bat-cat-git/src/bat/target/release/build/onig_sys-e90b5008d16a6589/build-script-build (exit code: 101) --- stdout cargo:warning=couldn't execute llvm-config --prefix (error: No such file or directory (os error 2)) cargo:warning=set the LLVM_CONFIG_PATH environment variable to a valid llvm-config executable

--- stderr thread 'main' panicked at 'Unable to find libclang: "couldn\'t find any valid shared libraries matching: [\'libclang.so\', \'libclang-.so\', \'libclang.so.\'], set the LIBCLANG_PATH env ironment variable to a path where one of these files can be found (invalid: [])"', src/libcore/result.rs:999:5 note: Run with RUST_BACKTRACE=1 environment variable to display a backtrace.

==> ERROR: A failure occurred in build(). Aborting...