Package Details: basiliskii-git r2667.4671258b-1

Git Clone URL: https://aur.archlinux.org/basiliskii-git.git (read-only, click to copy)
Package Base: basiliskii-git
Description: Open Source 68k Macintosh Emulator
Upstream URL: https://basilisk.cebix.net
Keywords: 68k basilisk color Emulator II Macintosh motorola
Licenses: GPL
Conflicts: basiliskii
Provides: basiliskii
Submitter: T3RM1NU5
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 10
Popularity: 0.090488
First Submitted: 2016-06-08 15:14
Last Updated: 2021-05-09 10:12

Latest Comments

kerobaros commented on 2021-04-03 22:14

Here's a new PKGBUILD and patch file using aocard's previous reply as a source. Built locally, works here, etc

https://gist.github.com/kerobaros/78a5eb2d869f94e23766147c6b4ed451

aocard commented on 2021-01-24 03:42

I was unable to build due to a complaint on a missing config.rpath file. As seen on https://github.com/cebix/macemu/issues/233, here is a patch:

--- src/macemu/BasiliskII/src/Unix/configure.ac 2021-01-23 22:21:57.989814552 -0500
+++ configure.ac    2021-01-23 22:33:55.409812229 -0500
@@ -483,10 +483,6 @@
   AM_PATH_GTK(1.2.0, [
     GUI_CFLAGS="$GTK_CFLAGS"
     GUI_LIBS="$GTK_LIBS"
-    dnl somehow, <gnome-i18n.h> would redefine gettext() to nothing if
-    dnl ENABLE_NLS is not set, thusly conflicting with C++ <string> which
-    dnl includes <libintl.h>
-    AM_GNU_GETTEXT([external])
     B2_PATH_GNOMEUI([
       AC_DEFINE(HAVE_GNOMEUI, 1, [Define if libgnomeui is available.])
       GUI_CFLAGS="$GUI_CFLAGS $GNOMEUI_CFLAGS"

hildigerr commented on 2020-04-23 22:26

I was unable to build.

sshpty.c: In function ‘pty_allocate’:
sshpty.c:190:20: error: ‘I_PUSH’ undeclared (first use in this function)
  190 |  if (ioctl(*ttyfd, I_PUSH, "ptem") < 0)
      |                    ^~~~~~
sshpty.c:190:20: note: each undeclared identifier is reported only once for each function it appears in
make: *** [Makefile:192: obj/sshpty.o] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

I got it to build with a hack: adding the following the the PKGBUILD, in build() after cd.

sed -i "/I_PUSH/d" sshpty.c

graysky commented on 2020-03-29 14:14

I am unable to build:

...
./../user_strings.cpp:206:3: error: ‘STR_MODELID_7_LAB’ was not declared in this scope; did you mean ‘STR_MODELID_5_LAB’?
  206 |  {STR_MODELID_7_LAB, "Mac IIfx (MacOS 7.x)"},
      |   ^~~~~~~~~~~~~~~~~
      |   STR_MODELID_5_LAB
./../user_strings.cpp:207:3: error: ‘STR_MODELID_12_LAB’ was not declared in this scope; did you mean ‘STR_MODELID_14_LAB’?
  207 |  {STR_MODELID_12_LAB, "Mac IIsi (MacOS 7.x"},
      |   ^~~~~~~~~~~~~~~~~~
      |   STR_MODELID_14_LAB
./../user_strings.cpp:208:3: error: ‘STR_MODELID_13_LAB’ was not declared in this scope; did you mean ‘STR_MODELID_14_LAB’?
  208 |  {STR_MODELID_13_LAB, "Mac LC (MacOS 7.x"},
      |   ^~~~~~~~~~~~~~~~~~
      |   STR_MODELID_14_LAB
...

ubuntuxp commented on 2018-12-15 01:23

Since this PKGBUILD builds architecture-specific packages, the arch=('any') needs to be changed to arch=('x86_64') (optionally with 'i686' and/or 'armv7h' included).